build: Pass -iremap gcc option as a single argument
authorMichal Sojka <sojkam1@fel.cvut.cz>
Thu, 2 Feb 2017 11:13:03 +0000 (12:13 +0100)
committerFelix Fietkau <nbd@nbd.name>
Thu, 9 Feb 2017 13:49:34 +0000 (14:49 +0100)
Passing -iremap argument separately causes problems with projects that
use scons and its ParseFlags function. Consider this SConscript
example:

    env = Environment()
    d = env.ParseFlags("-iremap one:two")

ParseFlags will interpret one:two as a file name and the returned dict
d will contain only "-iremap". When the -iremap is passed to the
compiler without an argument, compilation obviously fails.

Signed-off-by: Michal Sojka <sojkam1@fel.cvut.cz>
rules.mk

index 5d30baba8563311b403a3a7f3c85c626ba3a07ac..a3fe50b1dc0dfb4d1586ceb5bbf85a3fd36f5ebf 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -139,7 +139,7 @@ else
 endif
 
 ifeq ($(or $(CONFIG_EXTERNAL_TOOLCHAIN),$(CONFIG_GCC_VERSION_4_8),$(CONFIG_TARGET_uml)),)
-  iremap = -iremap $(1):$(2)
+  iremap = -iremap$(1):$(2)
 endif
 
 PACKAGE_DIR:=$(BIN_DIR)/packages