kernel: bump 4.14 to 4.14.82
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 21 Nov 2018 09:48:37 +0000 (10:48 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 22 Nov 2018 09:51:27 +0000 (10:51 +0100)
Refreshed all patches.

Compile-tested: cns3xxx, imx6, x86_64
Runtime-tested: cns3xxx, imx6, x86_64

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/backport-4.14/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/pending-4.14/330-MIPS-kexec-Accept-command-line-parameters-from-users.patch
target/linux/lantiq/patches-4.14/0001-MIPS-lantiq-add-pcie-driver.patch

index 22f279ef7b6baab6d6f6e233d34f5601ced23811..fc333b073644d60b25be55d03dee332b5710a4b3 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .138
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .138
-LINUX_VERSION-4.14 = .81
+LINUX_VERSION-4.14 = .82
 
 LINUX_KERNEL_HASH-4.9.138 = 92301242601d50854b173a3fdec318480e24fc86f32102003a9ed7108fab21b7
 
 LINUX_KERNEL_HASH-4.9.138 = 92301242601d50854b173a3fdec318480e24fc86f32102003a9ed7108fab21b7
-LINUX_KERNEL_HASH-4.14.81 = 4b36dfd053844ef0617799d432eed67aa4795d3403216d6789288aa7a0e75bde
+LINUX_KERNEL_HASH-4.14.82 = a790a2e6f6a76d70decec91d1b7bcfba90f821b076273da070f6e0e1e6391dad
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 5aae823ed7fe03bb2aadede782f01f4e3df1a4eb..7788dd14349942f36464b95dc2209522a9a4ebff 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                if (nf_ct_is_expired(tmp)) {
                        nf_ct_gc_expired(tmp);
                        continue;
                if (nf_ct_is_expired(tmp)) {
                        nf_ct_gc_expired(tmp);
                        continue;
-@@ -975,6 +978,18 @@ static bool gc_worker_can_early_drop(con
+@@ -978,6 +981,18 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
        return false;
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1011,6 +1026,11 @@ static void gc_worker(struct work_struct
+@@ -1014,6 +1029,11 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index e68395c69e18e89844cf654d71c7bc27126c0301..e17b4b62049bcdf4aa6daf440f2ccccd858664ee 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -978,18 +978,6 @@ static bool gc_worker_can_early_drop(con
+@@ -981,18 +981,6 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
        return false;
  }
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1026,10 +1014,8 @@ static void gc_worker(struct work_struct
+@@ -1029,10 +1017,8 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 86aed4f0f7688eb312a036e3dc3f9d62d6e3245f..1187543a46f1ddbd4aad2e5c77e790cda531b9b6 100644 (file)
@@ -184,7 +184,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
  
        /*
         * The generic kexec code builds a page list with physical
  
        /*
         * The generic kexec code builds a page list with physical
-@@ -121,15 +235,16 @@ machine_kexec(struct kimage *image)
+@@ -124,15 +238,16 @@ machine_kexec(struct kimage *image)
        /*
         * we do not want to be bothered.
         */
        /*
         * we do not want to be bothered.
         */
index f72f39448b0d20e304bdd744b62743d647e33b47..48dd111cca3c32c646bcd5b87da8c8d532caf058 100644 (file)
@@ -4143,7 +4143,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +
 --- a/arch/mips/pci/pci-legacy.c
 +++ b/arch/mips/pci/pci-legacy.c
 +
 --- a/arch/mips/pci/pci-legacy.c
 +++ b/arch/mips/pci/pci-legacy.c
-@@ -309,3 +309,30 @@ char *__init pcibios_setup(char *str)
+@@ -313,3 +313,30 @@ char *__init pcibios_setup(char *str)
                return pcibios_plat_setup(str);
        return str;
  }
                return pcibios_plat_setup(str);
        return str;
  }