gdb: bump to 8.2
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 6 Sep 2018 12:44:17 +0000 (14:44 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 7 Sep 2018 15:21:24 +0000 (17:21 +0200)
*** Changes in GDB 8.2

 Support for the following target has been added:

    RiscV ELF (riscv*-*-elf)

 Support for following targets and native configurations has been removed:

    m88k running OpenBSD (m88*-*-openbsd*)
    SH-5/SH64 ELF (sh64-*-elf*)
    SH-5/SH64 (sh*)
    SH-5/SH64 running GNU/Linux (sh*-*-linux*)
    SH-5/SH64 running OpenBSD (sh*-*-openbsd*)

 Various Python API enhancements
 Aarch64/Linux enhancements:

    SVE support.
    Hardware watchpoints improvements for entities stored at unaligned addresses.
        New "c" response to disable the pager for the rest of the current command.
        C expressions can now use _Alignof, and C++ expressions can now use alignof.
        Improved flexibility for loading symbol files.
        The 'info proc' command nows works on running processes on FreeBSD systems as well as core files created on FreeBSD systems.
        A new --enable-codesign=CERT configure option to automatically codesign GDB after build (useful on MacOS X).

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
package/devel/gdb/Makefile
package/devel/gdb/patches/100-musl_fix.patch
package/devel/gdb/patches/110-shared_libgcc.patch

index 446ea951257fc3a5a1dc265d130782d41fae282d..9e816697c12a2b33df3e4e5cbf5151ff839299a1 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=8.1.1
+PKG_VERSION:=8.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=97dcc3169bd430270fc29adb65145846a58c1b55cdbb73382a4a89307bdad03c
+PKG_HASH:=c3a441a29c7c89720b734e5a9c6289c0a06be7e0c76ef538f7bbcef389347c39
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
index b167fe6ecd7ff5182e421cd95e587ac052e54b20..356d8c41116d95481ed9845f358cb01225af3cf5 100644 (file)
@@ -49,5 +49,5 @@
  #include <asm/ptrace.h>
 +#undef pt_regs
  
- #include "nat/ppc-linux.h"
- #include "linux-ppc-tdesc.h"
+ #include "arch/ppc-linux-common.h"
+ #include "arch/ppc-linux-tdesc.h"
index 84d1f60f2fe01140ab27a24d5aa5c84c7250dc8d..c8ddfde5cca908f208fc9078413f8293304bdd71 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1293,13 +1293,13 @@ if test -z "$LD"; then
+@@ -1277,13 +1277,13 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -15,9 +15,9 @@
 +  LDFLAGS="$LDFLAGS -static-libstdc++"
 +  AC_MSG_CHECKING([whether g++ accepts -static-libstdc++])
    AC_LANG_PUSH(C++)
-   AC_LINK_IFELSE([
+   AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1625,7 +1625,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1609,7 +1609,7 @@ AC_ARG_WITH(stage1-ldflags,
   # if supported.  But if the user explicitly specified the libraries to use,
   # trust that they are doing what they want.
   if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
@@ -26,7 +26,7 @@
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1654,7 +1654,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1638,7 +1638,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
-@@ -4998,14 +4998,14 @@ if test -z "$LD"; then
+@@ -5043,14 +5043,14 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -56,7 +56,7 @@
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -5788,7 +5788,7 @@ else
+@@ -5833,7 +5833,7 @@ else
   # if supported.  But if the user explicitly specified the libraries to use,
   # trust that they are doing what they want.
   if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
   fi
  fi
  
-@@ -5824,7 +5824,7 @@ else
+@@ -5869,7 +5869,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then