mxs: i2c changes - add package for i2c module - remove i2c debug
authorZoltan Herpai <wigyori@uid0.hu>
Fri, 12 Dec 2014 11:39:22 +0000 (11:39 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Fri, 12 Dec 2014 11:39:22 +0000 (11:39 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 43648

target/linux/mxs/config-3.14
target/linux/mxs/modules.mk

index bded4131d9da23bed9a0dd7e1a3518d13af0b800..ead8dc357714625786d193b436cf6d0cc3178301 100644 (file)
@@ -157,15 +157,12 @@ CONFIG_I2C_ALGOPCF=y
 CONFIG_I2C_BOARDINFO=y
 CONFIG_I2C_CHARDEV=y
 CONFIG_I2C_COMPAT=y
-CONFIG_I2C_DEBUG_ALGO=y
-CONFIG_I2C_DEBUG_BUS=y
-CONFIG_I2C_DEBUG_CORE=y
 CONFIG_I2C_MUX=y
 # CONFIG_I2C_MUX_GPIO is not set
 # CONFIG_I2C_MUX_PCA9541 is not set
 # CONFIG_I2C_MUX_PCA954x is not set
 CONFIG_I2C_MUX_PINCTRL=y
-CONFIG_I2C_MXS=y
+# CONFIG_I2C_MXS is not set
 CONFIG_IIO=y
 CONFIG_IIO_BUFFER=y
 CONFIG_IIO_KFIFO_BUF=y
index afcf23865c1ed7813628aa4926bacf86f3f2eac7..75d668a1d098ce736b420c76665c911a286e8359 100644 (file)
@@ -99,3 +99,18 @@ define KernelPackage/spi-mxs/description
 endef
 
 $(eval $(call KernelPackage,spi-mxs))
+
+I2C_MXS_MODULES:= \
+  CONFIG_I2C_MXS:drivers/i2c/busses/i2c-mxs
+
+define KernelPackage/i2c-mxs
+  $(call i2c_defaults,$(I2C_MXS_MODULES),55)
+  TITLE:=Freescale i.MX23/28 I2C driver
+  DEPENDS:=@TARGET_mxs +kmod-i2c-core
+endef
+
+define KernelPackage/i2c-mxs/description
+    Kernel module for Freescale i.MX23/28 I2C controller
+endef
+
+$(eval $(call KernelPackage,i2c-mxs))