ar71xx: YunCore AP90Q image supports also AP80Q
authorPiotr Dymacz <pepe2k@gmail.com>
Sun, 18 Feb 2018 11:39:45 +0000 (12:39 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Thu, 22 Feb 2018 17:53:22 +0000 (18:53 +0100)
Vendor released new model (AP80Q) which is identical from hardware point
of view with already supported AP90Q. Include AP80Q in machine name.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/generic.mk

index 7c0494bcc8d2793bafed8bda442010effa3d2e74..a9e235fa759146b798b1303dd287ef63d376c35b 100644 (file)
@@ -217,7 +217,7 @@ config ATH79_MACH_AP531B0
        select ATH79_DEV_WMAC
 
 config ATH79_MACH_AP90Q
        select ATH79_DEV_WMAC
 
 config ATH79_MACH_AP90Q
-       bool "YunCore AP90Q support"
+       bool "YunCore AP80Q/AP90Q support"
        select SOC_QCA953X
        select ATH79_DEV_ETH
        select ATH79_DEV_GPIO_BUTTONS
        select SOC_QCA953X
        select ATH79_DEV_ETH
        select ATH79_DEV_GPIO_BUTTONS
index 2e9d34d658f210fce938b9ffa8b45fec66e4e243..99fceca3a005a2730c86dea6dccc1fac9aa36f65 100644 (file)
@@ -1,6 +1,6 @@
 /*
  * Support for YunCore boards:
 /*
  * Support for YunCore boards:
- * - AP90Q
+ * - AP80Q/AP90Q
  * - CPE830
  *
  * Copyright (C) 2016 Piotr Dymacz <pepe2k@gmail.com>
  * - CPE830
  *
  * Copyright (C) 2016 Piotr Dymacz <pepe2k@gmail.com>
@@ -172,7 +172,7 @@ static void __init ap90q_setup(void)
                                 ap90q_leds_gpio);
 }
 
                                 ap90q_leds_gpio);
 }
 
-MIPS_MACHINE(ATH79_MACH_AP90Q, "AP90Q", "YunCore AP90Q", ap90q_setup);
+MIPS_MACHINE(ATH79_MACH_AP90Q, "AP90Q", "YunCore AP80Q/AP90Q", ap90q_setup);
 
 static void __init cpe830_setup(void)
 {
 
 static void __init cpe830_setup(void)
 {
index da98a811e116536b9d243cb0087f70f4e017cb3c..9127d3fe9232d5449a137075020fbba062207e23 100644 (file)
@@ -40,7 +40,7 @@ enum ath79_mach_type {
        ATH79_MACH_AP147_010,                   /* Atheros AP147-010 reference board */
        ATH79_MACH_AP152,                       /* Atheros AP152 reference board */
        ATH79_MACH_AP531B0,                     /* Rockeetech AP531B0 */
        ATH79_MACH_AP147_010,                   /* Atheros AP147-010 reference board */
        ATH79_MACH_AP152,                       /* Atheros AP152 reference board */
        ATH79_MACH_AP531B0,                     /* Rockeetech AP531B0 */
-       ATH79_MACH_AP90Q,                       /* YunCore AP90Q */
+       ATH79_MACH_AP90Q,                       /* YunCore AP80Q/AP90Q */
        ATH79_MACH_AP91_5G,                     /* ALFA Network AP91-5G */
        ATH79_MACH_AP96,                        /* Atheros AP96 */
        ATH79_MACH_ARCHER_C25_V1,               /* TP-LINK Archer C25 V1 board */
        ATH79_MACH_AP91_5G,                     /* ALFA Network AP91-5G */
        ATH79_MACH_AP96,                        /* Atheros AP96 */
        ATH79_MACH_ARCHER_C25_V1,               /* TP-LINK Archer C25 V1 board */
index 2158a9921a840b6c3953dad964b720e2da6b17f9..137716d43917e4c9b5921eac0b63bb9729e8067d 100644 (file)
@@ -125,7 +125,7 @@ endef
 TARGET_DEVICES += ap531b0
 
 define Device/ap90q
 TARGET_DEVICES += ap531b0
 
 define Device/ap90q
-  DEVICE_TITLE := YunCore AP90Q
+  DEVICE_TITLE := YunCore AP80Q/AP90Q
   BOARDNAME := AP90Q
   IMAGE_SIZE := 16000k
   MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
   BOARDNAME := AP90Q
   IMAGE_SIZE := 16000k
   MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro