ath10k-ct: Force loading mac80211 and ath modules.
authorBen Greear <greearb@candelatech.com>
Sat, 20 Jan 2018 00:27:03 +0000 (16:27 -0800)
committerJo-Philipp Wich <jo@mein.io>
Thu, 22 Mar 2018 08:09:54 +0000 (09:09 +0100)
They are not automatically loaded on IPQ4019 (at least) machines
for some reason.

Signed-off-by: Ben Greear <greearb@candelatech.com>
package/kernel/ath10k-ct/Makefile

index 83d3a05bd8530c47af587c8c17f12432dead45dd..8f9a8dd70f043c480900714dad14c09af329bd1b 100644 (file)
@@ -33,7 +33,7 @@ define KernelPackage/ath10k-ct
   FILES:=\
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_pci.ko \
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_core.ko
   FILES:=\
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_pci.ko \
        $(PKG_BUILD_DIR)/ath10k$(CT_KVER)/ath10k_core.ko
-  AUTOLOAD:=$(call AutoProbe,ath10k_pci)
+  AUTOLOAD:=$(call AutoProbe,mac80211 ath ath10k_pci)
 endef
 
 NOSTDINC_FLAGS = \
 endef
 
 NOSTDINC_FLAGS = \