brcm47xx: generic: include Ethernet drivers in standard image
authorRafał Miłecki <rafal@milecki.pl>
Wed, 4 Jan 2017 11:38:48 +0000 (12:38 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Wed, 4 Jan 2017 11:49:03 +0000 (12:49 +0100)
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/brcm47xx/image/Makefile

index 0074cf3eddbd22d442d7fe8e827a3a111c7ace83..1bf577e159a1741ce203f3bb8f1e32e376dd360c 100644 (file)
@@ -244,6 +244,11 @@ define Device/linksys-e3000-v1
 endef
 TARGET_DEVICES += linksys-e3000-v1
 
+# generic has Ethernet drivers as modules so overwrite standard image
+define Device/standard
+  DEVICE_TITLE := Image with LZMA loader and LZMA compressed kernel
+  DEVICE_PACKAGES := kmod-b44 kmod-bgmac kmod-tg3
+endef
 TARGET_DEVICES += standard
 endif