toolchain: eliminate the INSTALL_LIBSTDCPP config symbol and make c++ support mandato...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 9 May 2013 20:50:49 +0000 (20:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 9 May 2013 20:50:49 +0000 (20:50 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 36594

Config.in
include/uclibc++.mk
package/libs/ncurses/Makefile
package/libs/uclibc++/Makefile
package/toolchain/Makefile
rules.mk
toolchain/gcc/Config.in
toolchain/gcc/common.mk

index 5c154691dd2ca356486d20d462760d05de2122cf..9ad71e02cb2273bcc8bb33121ea19499f9fb25cd 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -704,21 +704,19 @@ menu "Global build settings"
                  Note that this will make the system libraries incompatible with most of the packages
                  that are not selected during the build process
 
                  Note that this will make the system libraries incompatible with most of the packages
                  that are not selected during the build process
 
-       if INSTALL_LIBSTDCPP
-               choice
-                       prompt "Preferred standard C++ library"
-                       default USE_LIBSTDCXX if USE_EGLIBC
-                       default USE_UCLIBCXX
-                       help
-                         Select the preferred standard C++ library for all packages that support this.
+       choice
+               prompt "Preferred standard C++ library"
+               default USE_LIBSTDCXX if USE_EGLIBC
+               default USE_UCLIBCXX
+               help
+                 Select the preferred standard C++ library for all packages that support this.
 
 
-                       config USE_UCLIBCXX
-                               bool "uClibc++"
+               config USE_UCLIBCXX
+                       bool "uClibc++"
 
 
-                       config USE_LIBSTDCXX
-                               bool "libstdc++"
-               endchoice
-       endif
+               config USE_LIBSTDCXX
+                       bool "libstdc++"
+       endchoice
 
 endmenu
 
 
 endmenu
 
index 89298e3f30bc645f6a8fb6e7903ed0620185f1a9..a1a61f26d419fdbebb0f9f94a60010a398a17f31 100644 (file)
@@ -5,7 +5,7 @@ ifndef DUMP
 endif
 
 PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
 endif
 
 PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
-CXX_DEPENDS = @INSTALL_LIBSTDCPP +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
+CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
 
 ifneq ($(CONFIG_USE_UCLIBCXX),)
  ifneq ($(CONFIG_CCACHE),)
 
 ifneq ($(CONFIG_USE_UCLIBCXX),)
  ifneq ($(CONFIG_CCACHE),)
index b3605265721a9dcbc482a6c38afe7c9754c34519..62ffdfb0a06342c8ad4338cb5e70fdf857db0c65 100644 (file)
@@ -67,11 +67,6 @@ CONFIGURE_ARGS += \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
-ifneq ($(CONFIG_INSTALL_LIBSTDCPP),y)
-CONFIGURE_ARGS += \
-       --without-cxx-binding
-endif
-
 ifeq ($(HOST_OS),FreeBSD)
        CONFIGURE_ARGS +=
                --with-terminfo=/usr/share/terminfo.db 
 ifeq ($(HOST_OS),FreeBSD)
        CONFIGURE_ARGS +=
                --with-terminfo=/usr/share/terminfo.db 
index 2dd8f6507ec51ddf8d3a85de618c9cfc4e7abc5a..15c2bce54bdb9153c1e82d3b009d1b9afe54b2c8 100644 (file)
@@ -26,7 +26,6 @@ define Package/uclibcxx
   NAME:=uclibc++
   SECTION:=libs
   CATEGORY:=Libraries
   NAME:=uclibc++
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@INSTALL_LIBSTDCPP
   TITLE:=C++ library for embedded systems
   URL:=http://cxx.uclibc.org/src/
 endef
   TITLE:=C++ library for embedded systems
   URL:=http://cxx.uclibc.org/src/
 endef
index 7eadaba0d4f9a794fd02c149768e298025bbee0a..202e9d095d6c4b9d1f1f348603e0df1fdc30f5a4 100644 (file)
@@ -84,7 +84,6 @@ define Package/libstdcpp
 $(call Package/gcc/Default)
   NAME:=libstdc++
   TITLE:=GNU Standard C++ Library v3
 $(call Package/gcc/Default)
   NAME:=libstdc++
   TITLE:=GNU Standard C++ Library v3
-  DEPENDS+=@INSTALL_LIBSTDCPP
 endef
 
 define Package/libstdcpp/config
 endef
 
 define Package/libstdcpp/config
index b9510057b64c08a18729367cb406b1fd7689ec6d..61c45a00906827620b565a1e73baed359fdaf128 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -202,7 +202,7 @@ HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_AR:=$(TARGET_CROSS)ar
 TARGET_RANLIB:=$(TARGET_CROSS)ranlib
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_AR:=$(TARGET_CROSS)ar
 TARGET_RANLIB:=$(TARGET_CROSS)ranlib
-TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
+TARGET_CXX:=$(TARGET_CROSS)g++
 KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 CP:=cp -fpR
 KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 CP:=cp -fpR
index b3fd5d665e26e9938fb1a3752c5b1219d10cb210..defb1b1b0e0bf5b3e68b2eb0d5be06bb5b505ec8 100644 (file)
@@ -71,13 +71,6 @@ config SJLJ_EXCEPTIONS
            frame unwinding exceptions handling routines.  Warning: increases
            code size and runtime memory usage.
 
            frame unwinding exceptions handling routines.  Warning: increases
            code size and runtime memory usage.
 
-config INSTALL_LIBSTDCPP
-       bool
-       prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
-       default y if !USE_MUSL
-       help
-           Build/install c++ compiler and libstdc++?
-
 config INSTALL_LIBGCJ
        bool
        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
 config INSTALL_LIBGCJ
        bool
        prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
index 2e10f8dbef0574431d84cfd671297e6288c9f2dd..688374e2498d6288232413a29903c522c9446e72 100644 (file)
@@ -93,7 +93,7 @@ HOST_STAMP_CONFIGURED:=$(GCC_BUILD_DIR)/.configured
 HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.gcc_$(GCC_VARIANT)_installed
 
 SEP:=,
 HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.gcc_$(GCC_VARIANT)_installed
 
 SEP:=,
-TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)"
+TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)"
 
 export libgcc_cv_fixed_point=no
 ifdef CONFIG_USE_UCLIBC
 
 export libgcc_cv_fixed_point=no
 ifdef CONFIG_USE_UCLIBC