ar71xx: add profile support for dir-835-a1
authorGabor Juhos <juhosg@openwrt.org>
Mon, 11 Mar 2013 15:55:17 +0000 (15:55 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 11 Mar 2013 15:55:17 +0000 (15:55 +0000)
Signed-off-by: Alexander Stadler <sa.maillists@univie.ac.at>
Patchwork: http://patchwork.openwrt.org/patch/3427/mbox/
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35959

target/linux/ar71xx/generic/profiles/d-link.mk
target/linux/ar71xx/image/Makefile

index b668ed26dd9fd674c03cc70472c49ee21b6ae327..f30e9b1ecb760d086febf32b8a585cbeb7a26113 100644 (file)
@@ -72,3 +72,14 @@ define Profile/DIR825C1/Description
 endef
 
 $(eval $(call Profile,DIR825C1))
+
+define Profile/DIR835A1
+       NAME:=D-Link DIR-835 rev. A1
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/DIR835A1/Description
+       Package set optimized for the D-Link DIR-835 rev. A1.
+endef
+
+$(eval $(call Profile,DIR835A1))
index 20caff83f534ea656de2375381c61948441c8d5c..8a15af9c8ccb76f8b32b9989d2f2efb825dafd48 100644 (file)
@@ -859,6 +859,7 @@ $(eval $(call SingleProfile,Cameo913x,$(fs_squash),TEW652BRP_RECOVERY,tew-652brp
 $(eval $(call SingleProfile,Cameo933x,$(fs_squash),TEW712BR,tew-712br,TEW-712BR,ttyATH0,115200,"HORNET-RT-TEW712BR-3"))
 
 $(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR825C1,dir-825-c1,DIR-825-C1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))
+$(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR835A1,dir-835-a1,DIR-835-A1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))
 
 $(eval $(call SingleProfile,CyberTAN,$(fs_64k),WRT160NL,wrt160nl,WRT160NL,ttyS0,115200,1.00.01))