ath10k-ct: update version to fix DFS for VHT160
authorHannu Nyman <hannu.nyman@iki.fi>
Sat, 27 Nov 2021 23:09:35 +0000 (01:09 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Nov 2021 12:57:41 +0000 (13:57 +0100)
Update ath10k-ct to get the upstream fix for
DFS support for VHT160 in the 5.15 based ath10k-ct.
(Switch from 5.10 to 5.15 surfaced the upstream regression.)

* refresh one patch

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch

index ea7705b1f91fe2a8102da4aefd787db103c771fa..278f6d737e3a593fbd75c53afc9950fb5b912f4c 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-11-21
-PKG_SOURCE_VERSION:=e8e166fee23226e5d495afbdb7ed681d747d115b
-PKG_MIRROR_HASH:=771193292242fd8c198e9e379aa90882b1f5a144fbd77e09fbc97aca8ffe84e1
+PKG_SOURCE_DATE:=2021-11-28
+PKG_SOURCE_VERSION:=dc350bbf41d987c5b2db54405bcc9ef3cd66d5db
+PKG_MIRROR_HASH:=92422485c7b92be840a40bf8d157bb6731d14d3811907b6cb4e4cfab0777b60d
 
 # Build the 5.15 ath10k-ct driver version.
 # Probably this should match as closely as
index 1591ac5adf08bf8126508f9751815d121e13c7c4..4c4a0edd57971f9ea4f2f32680ac5c2651470655 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-5.15/mac.c
 +++ b/ath10k-5.15/mac.c
-@@ -11519,7 +11519,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -11521,7 +11521,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS