mvebu: add support for the Armada XP GP board (DB-MV784MP-GP)
authorLuka Perkov <luka@openwrt.org>
Tue, 11 Feb 2014 02:07:47 +0000 (02:07 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 11 Feb 2014 02:07:47 +0000 (02:07 +0000)
This Armada XP GP board from Marvell comes with:

* 2GB DDR3 DIMM
* 1GB NAND flash (8-bit interface)
* 16MB NOR flash (16-bot interrface)
* 16MB SPI flash
* SDIO module
* 3 PCIe
* 1 SATA link
* 2 USB EHCI
* 1 internal SSD
* 4 Ethernet Gigabit
* 1 RS232 port over USB

Signed-off-by: Seif Mazareeb <seif.mazareeb@gmail.com>
SVN-Revision: 39568

target/linux/mvebu/base-files/lib/mvebu.sh
target/linux/mvebu/image/Makefile

index 727b6b586a2359abf2931f10a694986231c28fa2..5bc35ef32865d58f72ed2aa66eb0da51cb7965b7 100644 (file)
@@ -28,6 +28,9 @@ mvebu_board_detect() {
        *"PlatHome OpenBlocks AX3-4 board")
                name="openblocks-ax3-4"
                ;;
+       *"Marvell Armada XP GP Board")
+               name="armada-xp-gp"
+               ;;
        esac
 
        [ -z "$name" ] && name="unknown"
index 1e4a7910e359e35f072d9c1bfee7b516b5db1348..e89530a650e24db0ad3f798d7b1d5d19f38e5429 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 TARGET_DTBS := armada-xp-db armada-370-db armada-xp-openblocks-ax3-4 armada-370-mirabox \
-               armada-370-rd
+               armada-370-rd armada-xp-gp
 
 LOADADDR:=0x00008000