lantiq: fix brnImage signature for the VGV7510KW22BRN images
authorMathias Kresin <dev@kresin.me>
Sat, 28 Jan 2017 11:36:15 +0000 (12:36 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 28 Jan 2017 11:44:41 +0000 (12:44 +0100)
The VGV7510KW22BRN and VGV7519BRN do not have the same brnImage
signature. It was accidentally changed with ba42c1d ("lantiq: un-macro
the image building code").

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/lantiq/image/Makefile

index 0b976ac734b5374bc984e4836a350b48c8719226..cdc88b2fc6aeb337b0e34b09f245176f0ba72a06 100644 (file)
@@ -538,9 +538,9 @@ TARGET_DEVICES += VGV7510KW22NOR
 define Device/VGV7510KW22BRN
   $(Device/lantiqBrnImage)
   IMAGE_SIZE := 7168k
-  SIGNATURE := 5D00008000
+  SIGNATURE := BRNDA6431
   MAGIC := 0x12345678
-  CRC32_POLY := 0x2083b8ed
+  CRC32_POLY := 0x04c11db7
   DEVICE_TITLE := o2 Box 6431 / Arcadyan VGV7510KW22 (BRN)
   DEVICE_PACKAGES := kmod-rt2800-pci wpad-mini kmod-usb-dwc2 kmod-ltq-tapi kmod-ltq-vmmc
 endef