wireguard-tools: depend on kmod-wireguard
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Thu, 25 Feb 2021 18:20:12 +0000 (10:20 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 10 Apr 2021 12:21:32 +0000 (14:21 +0200)
To the vast majority of the users, wireguard-tools are not useful
without the underlying kernel module. The cornercase of only generating
keys and not using the secure tunnel is something that won't be done on
an embedded OpenWrt system often. On the other hand, maintaining a
separate meta-package only for this use case introduces extra
complexity. WireGuard changes for Linux 5.10 remove the meta-package.
So let's make wireguard-tools depend on kmod-wireguard
to make WireGuard easier to use without having to install multiple
packages.

Fixes: ea980fb9 ("wireguard: bump to 20191226")
Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
(cherry picked from commit cbcddc9f318607881799e329b327a68c4e76d5cb)

package/network/utils/wireguard-tools/Makefile

index ee332c28ef2cdefd674327ba1fd5223159dc70f5..5f8da147c16bfca67af3aea53450fbcb5c34fdd5 100644 (file)
@@ -36,7 +36,10 @@ define Package/wireguard-tools
   URL:=https://www.wireguard.com
   MAINTAINER:=Jason A. Donenfeld <Jason@zx2c4.com>
   TITLE:=WireGuard userspace control program (wg)
-  DEPENDS:=+@BUSYBOX_CONFIG_IP +@BUSYBOX_CONFIG_FEATURE_IP_LINK
+  DEPENDS:= \
+         +@BUSYBOX_CONFIG_IP \
+         +@BUSYBOX_CONFIG_FEATURE_IP_LINK \
+         +kmod-wireguard
 endef
 
 define Package/wireguard-tools/description