kernel: bump 4.14 to 4.14.156
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Nov 2019 10:32:58 +0000 (11:32 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 29 Nov 2019 09:01:27 +0000 (10:01 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
22 files changed:
include/kernel-version.mk
target/linux/cns3xxx/patches-4.14/070-i2c_support.patch
target/linux/gemini/patches-4.14/0002-pinctrl-gemini-Add-missing-functions.patch
target/linux/gemini/patches-4.14/0005-pinctrl-gemini-Use-generic-DT-parser.patch
target/linux/gemini/patches-4.14/0006-pinctrl-gemini-Implement-clock-skew-delay-config.patch
target/linux/gemini/patches-4.14/0007-pinctrl-gemini-Fix-GMAC-groups.patch
target/linux/gemini/patches-4.14/0009-pinctrl-gemini-Add-two-missing-GPIO-groups.patch
target/linux/gemini/patches-4.14/0010-pinctrl-gemini-Fix-usage-of-3512-groups.patch
target/linux/gemini/patches-4.14/0011-pinctrl-gemini-Support-drive-strength-setting.patch
target/linux/generic/backport-4.14/303-v4.16-netfilter-nf_tables-remove-multihook-chains-and-fami.patch
target/linux/generic/backport-4.14/335-v4.16-netfilter-nf_tables-add-single-table-list-for-all-fa.patch
target/linux/generic/pending-4.14/161-mtd-part-add-generic-parsing-of-linux-part-probe.patch
target/linux/ipq806x/patches-4.14/0048-PM-OPP-HACK-Allow-to-set-regulator-without-opp_list.patch
target/linux/ipq806x/patches-4.14/0049-PM-OPP-Support-adjusting-OPP-voltages-at-runtime.patch
target/linux/ipq806x/patches-4.14/0051-PM-OPP-Add-a-helper-to-get-an-opp-regulator-for-devi.patch
target/linux/ipq806x/patches-4.14/0052-PM-OPP-Update-the-voltage-tolerance-when-adjusting-t.patch
target/linux/lantiq/patches-4.14/0031-I2C-MIPS-lantiq-add-FALC-ON-i2c-bus-master.patch
target/linux/mediatek/patches-4.14/0173-clk-mediatek-fixup-test-building-of-MediaTek-clock-d.patch
target/linux/mxs/patches-4.14/110-crypto-mxsdcp-provide-importexport.patch
target/linux/oxnas/patches-4.14/500-oxnas-sata.patch
target/linux/ramips/patches-4.14/0044-i2c-MIPS-adds-ralink-I2C-driver.patch
target/linux/ramips/patches-4.14/0045-i2c-add-mt7621-driver.patch

index c9b2b2302a0fe3759a7ec76b8236632ead5a3aa8..e0f9daaeaa488b73e6a4b25fd54e6f78f3d1213d 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .202
-LINUX_VERSION-4.14 = .155
+LINUX_VERSION-4.14 = .156
 
 LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf
-LINUX_KERNEL_HASH-4.14.155 = 77d61979556b81c95b81452fa10e1fe9368cbe2f9f80a13e4669b0464722e481
+LINUX_KERNEL_HASH-4.14.156 = f8889feb0cbd7df36ff35bd4c72c1e2010567621bfcb218fcfa501bc5c7787c0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index bacec360857e68d0540477a30f627c9a5f5797be..53a6f7ff5eb4819a2646086b4ebf019313e5c5d0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -473,6 +473,18 @@ config I2C_CBUS_GPIO
+@@ -474,6 +474,18 @@ config I2C_CBUS_GPIO
          This driver can also be built as a module.  If so, the module
          will be called i2c-cbus-gpio.
  
index 604fee469c794afbe7ff5a29867a9636103eb9f1..d4e93f88b2917de8bd1a09dd8d381657cad1bf98 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
 
 --- a/drivers/pinctrl/pinctrl-gemini.c
 +++ b/drivers/pinctrl/pinctrl-gemini.c
-@@ -2074,6 +2074,16 @@ static const struct gemini_pmx_func gemi
+@@ -2102,6 +2102,16 @@ static const struct gemini_pmx_func gemi
                .num_groups = ARRAY_SIZE(satagrps),
        },
        {
index 5b0bba1cd4a6733c8c7c2da6b0e31e16d8e8a861..f9debdd9002082338fd0cf5183d3eea2aec4ae81 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  #include <linux/platform_device.h>
  #include <linux/slab.h>
  #include <linux/regmap.h>
-@@ -1918,73 +1920,13 @@ static void gemini_pin_dbg_show(struct p
+@@ -1946,73 +1948,13 @@ static void gemini_pin_dbg_show(struct p
        seq_printf(s, " " DRIVER_NAME);
  }
  
index 4bff3bce9c213cb1a96179507df09780d0e5607c..87a051e1b264afcee4316989c2cae30c5f1f90c9 100644 (file)
@@ -97,7 +97,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  #define GLOBAL_MISC_CTRL      0x30
  #define TVC_CLK_PAD_ENABLE    BIT(20)
  #define PCI_CLK_PAD_ENABLE    BIT(17)
-@@ -1925,7 +1946,7 @@ static const struct pinctrl_ops gemini_p
+@@ -1953,7 +1974,7 @@ static const struct pinctrl_ops gemini_p
        .get_group_name = gemini_get_group_name,
        .get_group_pins = gemini_get_group_pins,
        .pin_dbg_show = gemini_pin_dbg_show,
@@ -106,7 +106,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        .dt_free_map = pinconf_generic_dt_free_map,
  };
  
-@@ -2203,10 +2224,155 @@ static const struct pinmux_ops gemini_pm
+@@ -2232,10 +2253,155 @@ static const struct pinmux_ops gemini_pm
        .set_mux = gemini_pmx_set_mux,
  };
  
@@ -262,7 +262,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        .owner = THIS_MODULE,
  };
  
-@@ -2249,11 +2415,15 @@ static int gemini_pmx_probe(struct platf
+@@ -2278,11 +2444,15 @@ static int gemini_pmx_probe(struct platf
        val &= 0xffff;
        if (val == 0x3512) {
                pmx->is_3512 = true;
index 902168ba62a00c53fb8cffa59c91553e97cb6949..4a4dae34caa2c7b9aedd28a6433ddf772f80fb43 100644 (file)
@@ -55,7 +55,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  };
  
  static const unsigned int pci_3512_pins[] = {
-@@ -668,10 +678,10 @@ static const unsigned int gpio1c_3512_pi
+@@ -671,10 +681,10 @@ static const unsigned int gpio1c_3512_pi
  /* The GPIO1D (28-31) pins overlap with LCD and TVC */
  static const unsigned int gpio1d_3512_pins[] = { 246, 319, 301, 283 };
  
@@ -68,7 +68,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  static const unsigned int gpio2b_3512_pins[] = { 262, 244, 317, 299 };
  
  /* The GPIO2C (8-31) pins overlap with PCI */
-@@ -738,9 +748,16 @@ static const struct gemini_pin_group gem
+@@ -741,9 +751,16 @@ static const struct gemini_pin_group gem
                .num_pins = ARRAY_SIZE(usb_3512_pins),
        },
        {
@@ -88,7 +88,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "pcigrp",
-@@ -954,14 +971,15 @@ static const struct gemini_pin_group gem
+@@ -963,14 +980,15 @@ static const struct gemini_pin_group gem
                .name = "gpio2agrp",
                .pins = gpio2a_3512_pins,
                .num_pins = ARRAY_SIZE(gpio2a_3512_pins),
@@ -107,7 +107,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "gpio2cgrp",
-@@ -1441,9 +1459,12 @@ static const unsigned int usb_3516_pins[
+@@ -1450,9 +1468,12 @@ static const unsigned int usb_3516_pins[
  };
  
  /* GMII, ethernet pins */
@@ -123,7 +123,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  };
  
  static const unsigned int pci_3516_pins[] = {
-@@ -1585,10 +1606,10 @@ static const unsigned int gpio1c_3516_pi
+@@ -1600,10 +1621,10 @@ static const unsigned int gpio1c_3516_pi
  /* The GPIO1D (28-31) pins overlap with TVC */
  static const unsigned int gpio1d_3516_pins[] = { 353, 311, 394, 374 };
  
@@ -136,7 +136,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  static const unsigned int gpio2b_3516_pins[] = { 391, 351, 310, 371 };
  
  /* The GPIO2C (8-31) pins overlap with PCI */
-@@ -1660,9 +1681,16 @@ static const struct gemini_pin_group gem
+@@ -1675,9 +1696,16 @@ static const struct gemini_pin_group gem
                .num_pins = ARRAY_SIZE(usb_3516_pins),
        },
        {
@@ -156,7 +156,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "pcigrp",
-@@ -1861,14 +1889,15 @@ static const struct gemini_pin_group gem
+@@ -1889,14 +1917,15 @@ static const struct gemini_pin_group gem
                .name = "gpio2agrp",
                .pins = gpio2a_3516_pins,
                .num_pins = ARRAY_SIZE(gpio2a_3516_pins),
@@ -175,7 +175,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "gpio2cgrp",
-@@ -1971,7 +2000,7 @@ static const char * const icegrps[] = {
+@@ -1999,7 +2028,7 @@ static const char * const icegrps[] = {
  static const char * const idegrps[] = { "idegrp" };
  static const char * const satagrps[] = { "satagrp" };
  static const char * const usbgrps[] = { "usbgrp" };
index 46fc102c1d33c112dd3fb6ba53668a6699bcb5d6..dfb93f6ade489429ae8f0c0c1778e2c9b70ba745 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
 
 --- a/drivers/pinctrl/pinctrl-gemini.c
 +++ b/drivers/pinctrl/pinctrl-gemini.c
-@@ -2015,7 +2015,8 @@ static const char * const sflashgrps[] =
+@@ -2043,7 +2043,8 @@ static const char * const sflashgrps[] =
  static const char * const gpio0grps[] = { "gpio0agrp", "gpio0bgrp", "gpio0cgrp",
                                          "gpio0dgrp", "gpio0egrp", "gpio0fgrp",
                                          "gpio0ggrp", "gpio0hgrp", "gpio0igrp",
index 1cab269a64938eb009ff4ddcb2b09ba3c3703943..f01edb9bffeb58ae60c085bb1642687f2a996cae 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
 
 --- a/drivers/pinctrl/pinctrl-gemini.c
 +++ b/drivers/pinctrl/pinctrl-gemini.c
-@@ -2323,7 +2323,7 @@ static const struct gemini_pin_conf *gem
+@@ -2352,7 +2352,7 @@ static const struct gemini_pin_conf *gem
        int i;
  
        for (i = 0; i < pmx->nconfs; i++) {
index 5fefece493e3fef040b3d1f4939a62df0a85a4ad..e6d153403e3995805d993c1c7034dd6704fd7f3b 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
  #define GLOBAL_GMAC_CTRL_SKEW 0x1c
  #define GLOBAL_GMAC0_DATA_SKEW        0x20
  #define GLOBAL_GMAC1_DATA_SKEW        0x24
-@@ -738,6 +743,7 @@ static const struct gemini_pin_group gem
+@@ -741,6 +746,7 @@ static const struct gemini_pin_group gem
                /* Conflict with all flash usage */
                .value = IDE_PADS_ENABLE | NAND_PADS_DISABLE |
                        PFLASH_PADS_DISABLE | SFLASH_PADS_DISABLE,
@@ -62,7 +62,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "satagrp",
-@@ -753,6 +759,7 @@ static const struct gemini_pin_group gem
+@@ -756,6 +762,7 @@ static const struct gemini_pin_group gem
                .name = "gmii_gmac0_grp",
                .pins = gmii_gmac0_3512_pins,
                .num_pins = ARRAY_SIZE(gmii_gmac0_3512_pins),
@@ -70,7 +70,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "gmii_gmac1_grp",
-@@ -760,6 +767,7 @@ static const struct gemini_pin_group gem
+@@ -763,6 +770,7 @@ static const struct gemini_pin_group gem
                .num_pins = ARRAY_SIZE(gmii_gmac1_3512_pins),
                /* Bring out RGMII on the GMAC1 pins */
                .value = GEMINI_GMAC_IOSEL_GMAC0_GMAC1_RGMII,
@@ -78,7 +78,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "pcigrp",
-@@ -767,6 +775,7 @@ static const struct gemini_pin_group gem
+@@ -770,6 +778,7 @@ static const struct gemini_pin_group gem
                .num_pins = ARRAY_SIZE(pci_3512_pins),
                /* Conflict only with GPIO2 */
                .value = PCI_PADS_ENABLE | PCI_CLK_PAD_ENABLE,
@@ -86,7 +86,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "lpcgrp",
-@@ -1671,6 +1680,7 @@ static const struct gemini_pin_group gem
+@@ -1686,6 +1695,7 @@ static const struct gemini_pin_group gem
                /* Conflict with all flash usage */
                .value = IDE_PADS_ENABLE | NAND_PADS_DISABLE |
                        PFLASH_PADS_DISABLE | SFLASH_PADS_DISABLE,
@@ -94,7 +94,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "satagrp",
-@@ -1686,6 +1696,7 @@ static const struct gemini_pin_group gem
+@@ -1701,6 +1711,7 @@ static const struct gemini_pin_group gem
                .name = "gmii_gmac0_grp",
                .pins = gmii_gmac0_3516_pins,
                .num_pins = ARRAY_SIZE(gmii_gmac0_3516_pins),
@@ -102,7 +102,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "gmii_gmac1_grp",
-@@ -1693,6 +1704,7 @@ static const struct gemini_pin_group gem
+@@ -1708,6 +1719,7 @@ static const struct gemini_pin_group gem
                .num_pins = ARRAY_SIZE(gmii_gmac1_3516_pins),
                /* Bring out RGMII on the GMAC1 pins */
                .value = GEMINI_GMAC_IOSEL_GMAC0_GMAC1_RGMII,
@@ -110,7 +110,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "pcigrp",
-@@ -1700,6 +1712,7 @@ static const struct gemini_pin_group gem
+@@ -1715,6 +1727,7 @@ static const struct gemini_pin_group gem
                .num_pins = ARRAY_SIZE(pci_3516_pins),
                /* Conflict only with GPIO2 */
                .value = PCI_PADS_ENABLE | PCI_CLK_PAD_ENABLE,
@@ -118,7 +118,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
        },
        {
                .name = "lpcgrp",
-@@ -2394,9 +2407,77 @@ static int gemini_pinconf_set(struct pin
+@@ -2423,9 +2436,77 @@ static int gemini_pinconf_set(struct pin
        return ret;
  }
  
index ed33b2fc5f8b232ff390dd3694059a44224891c7..a2388a1b9bb861ee638e1a5b019f88ad5b7f88b6 100644 (file)
@@ -361,7 +361,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  
                par->hook_mask = 1 << ops->hooknum;
        } else {
-@@ -318,7 +318,7 @@ static int nft_target_validate(const str
+@@ -337,7 +337,7 @@ static int nft_target_validate(const str
        if (nft_is_base_chain(ctx->chain)) {
                const struct nft_base_chain *basechain =
                                                nft_base_chain(ctx->chain);
@@ -370,7 +370,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  
                hook_mask = 1 << ops->hooknum;
                if (target->hooks && !(hook_mask & target->hooks))
-@@ -415,7 +415,7 @@ nft_match_set_mtchk_param(struct xt_mtch
+@@ -434,7 +434,7 @@ nft_match_set_mtchk_param(struct xt_mtch
        if (nft_is_base_chain(ctx->chain)) {
                const struct nft_base_chain *basechain =
                                                nft_base_chain(ctx->chain);
@@ -379,7 +379,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  
                par->hook_mask = 1 << ops->hooknum;
        } else {
-@@ -566,7 +566,7 @@ static int nft_match_validate(const stru
+@@ -586,7 +586,7 @@ static int nft_match_validate(const stru
        if (nft_is_base_chain(ctx->chain)) {
                const struct nft_base_chain *basechain =
                                                nft_base_chain(ctx->chain);
index a577e621bdd9cdb22c04a6cdc41efa7cf68afdd1..9108a5e4dcef4dea8c144d1a7dd6a627cf5477f7 100644 (file)
@@ -1237,7 +1237,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        if (par.target->destroy != NULL)
                par.target->destroy(&par);
  
-@@ -390,7 +390,7 @@ nft_match_set_mtchk_param(struct xt_mtch
+@@ -409,7 +409,7 @@ nft_match_set_mtchk_param(struct xt_mtch
  {
        par->net        = ctx->net;
        par->table      = ctx->table->name;
@@ -1246,7 +1246,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        case AF_INET:
                entry->e4.ip.proto = proto;
                entry->e4.ip.invflags = inv ? IPT_INV_PROTO : 0;
-@@ -421,7 +421,7 @@ nft_match_set_mtchk_param(struct xt_mtch
+@@ -440,7 +440,7 @@ nft_match_set_mtchk_param(struct xt_mtch
        } else {
                par->hook_mask = 0;
        }
@@ -1255,7 +1255,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        par->nft_compat = true;
  }
  
-@@ -504,7 +504,7 @@ __nft_match_destroy(const struct nft_ctx
+@@ -523,7 +523,7 @@ __nft_match_destroy(const struct nft_ctx
        par.net = ctx->net;
        par.match = match;
        par.matchinfo = info;
@@ -1264,7 +1264,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        if (par.match->destroy != NULL)
                par.match->destroy(&par);
  
-@@ -734,7 +734,7 @@ nft_match_select_ops(const struct nft_ct
+@@ -754,7 +754,7 @@ nft_match_select_ops(const struct nft_ct
  
        mt_name = nla_data(tb[NFTA_MATCH_NAME]);
        rev = ntohl(nla_get_be32(tb[NFTA_MATCH_REV]));
@@ -1273,7 +1273,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  
        /* Re-use the existing match if it's already loaded. */
        list_for_each_entry(nft_match, &nft_match_list, head) {
-@@ -825,7 +825,7 @@ nft_target_select_ops(const struct nft_c
+@@ -845,7 +845,7 @@ nft_target_select_ops(const struct nft_c
  
        tg_name = nla_data(tb[NFTA_TARGET_NAME]);
        rev = ntohl(nla_get_be32(tb[NFTA_TARGET_REV]));
index 80ff556a49d87cfe0b289706ee486ea39d7a836b..dd402a15c8e9c224beec01dcdaee893919f652c5 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  errors per {size} bytes".
 --- a/drivers/mtd/maps/physmap_of_core.c
 +++ b/drivers/mtd/maps/physmap_of_core.c
-@@ -114,37 +114,9 @@ static struct mtd_info *obsolete_probe(s
+@@ -105,37 +105,9 @@ static struct mtd_info *obsolete_probe(s
  static const char * const part_probe_types_def[] = {
        "cmdlinepart", "RedBoot", "ofpart", "ofoldpart", NULL };
  
@@ -78,7 +78,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
        const struct of_device_id *match;
        struct device_node *dp = dev->dev.of_node;
        struct resource res;
-@@ -310,14 +282,8 @@ static int of_flash_probe(struct platfor
+@@ -293,14 +265,8 @@ static int of_flash_probe(struct platfor
  
        info->cmtd->dev.parent = &dev->dev;
        mtd_set_of_node(info->cmtd, dp);
index cca2fcaa4fcd9ae2b2c80e87496819881f5f42c0..7c78d444f80f850ab13d5f2fbb3e5c9cc9a795a8 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
 
 --- a/drivers/base/power/opp/core.c
 +++ b/drivers/base/power/opp/core.c
-@@ -1292,11 +1292,13 @@ struct opp_table *dev_pm_opp_set_regulat
+@@ -1280,11 +1280,13 @@ struct opp_table *dev_pm_opp_set_regulat
        if (!opp_table)
                return ERR_PTR(-ENOMEM);
  
index 9f7c8185e9ad69d28113891e60d03c25592f97cd..ef48e9f01b89826912e9ebcb22b7c392013c2d06 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
 
 --- a/drivers/base/power/opp/core.c
 +++ b/drivers/base/power/opp/core.c
-@@ -1620,6 +1620,83 @@ put_table:
+@@ -1608,6 +1608,83 @@ put_table:
  }
  
  /**
index 7819dc0dd8c6d740e921ba13444845dc09a99930..22ae309801e5d0c712722eab223958d0dbc8a55c 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
 
 --- a/drivers/base/power/opp/core.c
 +++ b/drivers/base/power/opp/core.c
-@@ -131,6 +131,27 @@ unsigned long dev_pm_opp_get_freq(struct
+@@ -126,6 +126,27 @@ unsigned long dev_pm_opp_get_freq(struct
  }
  EXPORT_SYMBOL_GPL(dev_pm_opp_get_freq);
  
index 3105b4ea1b0de8608ff25e80f8c00e215fc3041f..7cde22be0b83b8f3faacb92b20f313147cd805c3 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
 
 --- a/drivers/base/power/opp/core.c
 +++ b/drivers/base/power/opp/core.c
-@@ -1664,6 +1664,7 @@ int dev_pm_opp_adjust_voltage(struct dev
+@@ -1652,6 +1652,7 @@ int dev_pm_opp_adjust_voltage(struct dev
        struct opp_table *opp_table;
        struct dev_pm_opp *new_opp, *tmp_opp, *opp = ERR_PTR(-ENODEV);
        int r = 0;
@@ -25,7 +25,7 @@ Signed-off-by: Georgi Djakov <georgi.djakov@linaro.org>
  
        /* keep the node allocated */
        new_opp = kmalloc(sizeof(*new_opp), GFP_KERNEL);
-@@ -1700,6 +1701,10 @@ int dev_pm_opp_adjust_voltage(struct dev
+@@ -1688,6 +1689,10 @@ int dev_pm_opp_adjust_voltage(struct dev
  
        /* plug in new node */
        new_opp->supplies[0].u_volt = u_volt;
index a1e1cceddc605b526f8a0c3558f721c3eb39d13c..a1d92c39e232c9787aa2efd38d8afad3567db97f 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -696,6 +696,16 @@ config I2C_MESON
+@@ -697,6 +697,16 @@ config I2C_MESON
          If you say yes to this option, support will be included for the
          I2C interface on the Amlogic Meson family of SoCs.
  
index f8a755003a1624ac6c619ba1f59c6c860cd028c0..259a93cf2f3ce70491396f1430b09f5c4271cf1b 100644 (file)
@@ -16,8 +16,8 @@ Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
 
 --- a/drivers/clk/Makefile
 +++ b/drivers/clk/Makefile
-@@ -67,7 +67,7 @@ obj-$(CONFIG_ARCH_MXC)                       += imx/
- obj-$(CONFIG_MACH_INGENIC)            += ingenic/
+@@ -68,7 +68,7 @@ obj-$(CONFIG_MACH_INGENIC)           += ingenic/
+ obj-$(CONFIG_ARCH_K3)                 += keystone/
  obj-$(CONFIG_ARCH_KEYSTONE)           += keystone/
  obj-$(CONFIG_MACH_LOONGSON32)         += loongson1/
 -obj-$(CONFIG_ARCH_MEDIATEK)           += mediatek/
index 3be3e1a111e428f96f4ace21fc68bfff4b93114c..4a1722a66369d9e18ed073492f17a1987211adec 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/crypto/mxs-dcp.c
 +++ b/drivers/crypto/mxs-dcp.c
-@@ -777,6 +777,24 @@ static void dcp_sha_cra_exit(struct cryp
+@@ -833,6 +833,24 @@ static void dcp_sha_cra_exit(struct cryp
  {
  }
  
@@ -25,7 +25,7 @@
  /* AES 128 ECB and AES 128 CBC */
  static struct crypto_alg dcp_aes_algs[] = {
        {
-@@ -836,8 +854,11 @@ static struct ahash_alg dcp_sha1_alg = {
+@@ -892,8 +910,11 @@ static struct ahash_alg dcp_sha1_alg = {
        .final  = dcp_sha_final,
        .finup  = dcp_sha_finup,
        .digest = dcp_sha_digest,
@@ -37,7 +37,7 @@
                .base           = {
                        .cra_name               = "sha1",
                        .cra_driver_name        = "sha1-dcp",
-@@ -860,8 +881,11 @@ static struct ahash_alg dcp_sha256_alg =
+@@ -916,8 +937,11 @@ static struct ahash_alg dcp_sha256_alg =
        .final  = dcp_sha_final,
        .finup  = dcp_sha_finup,
        .digest = dcp_sha_digest,
index f79b100a5ed356d4c70c3cccf89ae4216f89eb80..cd0219a0b538371d667157b19646119d4786ad11 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
-@@ -492,6 +492,13 @@ config SATA_VITESSE
+@@ -493,6 +493,13 @@ config SATA_VITESSE
  
          If unsure, say N.
  
index 471c8f40e0bbf92fc96aab9037d15ec9cc11ec14..4905aba046c5856dfdb1a7586c62610fbc307135 100644 (file)
@@ -45,7 +45,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +};
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -863,6 +863,11 @@ config I2C_RK3X
+@@ -864,6 +864,11 @@ config I2C_RK3X
          This driver can also be built as a module. If so, the module will
          be called i2c-rk3x.
  
index 9cd8c4b5cf595b9179e0625e45c3ca03950b633f..a848085520f96be0510b7bfc4b379e3ad206e958 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -868,6 +868,11 @@ config I2C_RALINK
+@@ -869,6 +869,11 @@ config I2C_RALINK
        depends on RALINK && !SOC_MT7621
        select OF_I2C