kernel: only depend on kmod-rtc-core if its provided by the used Kernel version
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 25 Feb 2012 13:05:59 +0000 (13:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 25 Feb 2012 13:05:59 +0000 (13:05 +0000)
SVN-Revision: 30716

package/kernel/modules/other.mk

index ff42ebada51eb63f03248cdcaf2032c2d89f0e77..9ab6700b7fc8363f0e0e1e1ae8a683ca7299e8cd 100644 (file)
@@ -751,7 +751,7 @@ $(eval $(call KernelPackage,rtc-core))
 define KernelPackage/rtc-pcf8563
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Philips PCF8563/Epson RTC8564 RTC support
-  DEPENDS:=+kmod-rtc-core
+  DEPENDS:=+(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN):kmod-rtc-core
   KCONFIG:=CONFIG_RTC_DRV_PCF8563
   FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf8563.ko
   AUTOLOAD:=$(call AutoLoad,60,rtc-pcf8563)
@@ -768,7 +768,7 @@ $(eval $(call KernelPackage,rtc-pcf8563))
 define KernelPackage/rtc-pcf2123
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Philips PCF2123 RTC support
-  DEPENDS:=+kmod-rtc-core
+  DEPENDS:=+(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN):kmod-rtc-core
   KCONFIG:=CONFIG_RTC_DRV_PCF2123
   FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
   AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)