lantiq: several a803 related fixes
authorJohn Crispin <john@openwrt.org>
Mon, 5 Aug 2013 10:42:00 +0000 (10:42 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 5 Aug 2013 10:42:00 +0000 (10:42 +0000)
based on work from Matti Laasko that he posted in the wiki

Signed-off-by: John Crispin <blogic@openwrt.or
SVN-Revision: 37704

target/linux/lantiq/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/lantiq/base-files/etc/uci-defaults/02_network
target/linux/lantiq/dts/ARV752DPW22.dts
target/linux/lantiq/xway/profiles/arv.mk

index 3f9282805d7fc1621560160ae847dde7126e1f29..7ec8d6fd21437daf73276ff657f5f9f75bcc99dd 100644 (file)
@@ -29,7 +29,7 @@ case "$FIRMWARE" in
 "RT2860.eeprom" )
        local board=$(lantiq_board_id)
        case $board in
 "RT2860.eeprom" )
        local board=$(lantiq_board_id)
        case $board in
-       ARV7525PW|ARV752DPW)
+       ARV7525PW|ARV752DPW|ARV752DPW22)
                rt2x00_eeprom_extract "board_config" 1040 512
                ;;
        *)
                rt2x00_eeprom_extract "board_config" 1040 512
                ;;
        *)
index 1d3a1177b0b9cb0521290cf748ec752a55410c40..f5401c3edd5f737dff6a2d0dbb8cdef980eef7ae 100755 (executable)
@@ -58,7 +58,7 @@ ACMP252|GIGASX76X)
        ;;
 
 # ar8316
        ;;
 
 # ar8316
-ARV4519PW|ARV7518PW)
+ARV4519PW|ARV7518PW|ARV752DPW22)
        ucidef_set_interface_lan "eth0.1"
        ucidef_add_switch "switch0" "1" "1"
        ucidef_add_switch_vlan "switch0" "1" "0t 2 3 4 5"
        ucidef_set_interface_lan "eth0.1"
        ucidef_add_switch "switch0" "1" "1"
        ucidef_add_switch_vlan "switch0" "1" "0t 2 3 4 5"
index a9b1ae039ade9425cac5999f6491c3291fef88d2..983386dc26c8cc46dbc2884f859a23e928c36661 100644 (file)
 
                                partition@0 {
                                        label = "uboot";
 
                                partition@0 {
                                        label = "uboot";
-                                       reg = <0x00000 0x10000>;
+                                       reg = <0x00000 0x30000>;
                                        read-only;
                                };
 
                                partition@10000 {
                                        label = "uboot_env";
                                        read-only;
                                };
 
                                partition@10000 {
                                        label = "uboot_env";
-                                       reg = <0x10000 0x10000>;
+                                       reg = <0x30000 0x10000>;
                                        read-only;
                                };
 
                                partition@20000 {
                                        label = "linux";
                                        read-only;
                                };
 
                                partition@20000 {
                                        label = "linux";
-                                       reg = <0x20000 0x7d0000>;
+                                       reg = <0x40000 0x7b0000>;
                                };
 
                                partition@7f0000 {
                                };
 
                                partition@7f0000 {
                                        lantiq,output = <0>;
                                };
                                pci_in {
                                        lantiq,output = <0>;
                                };
                                pci_in {
-                                       lantiq,groups = "req1", "req2";
+                                       lantiq,groups = "req1";
                                        lantiq,function = "pci";
                                        lantiq,function = "pci";
-                                       lantiq,open-drain = <1>;
                                        lantiq,pull = <2>;
                                        lantiq,output = <0>;
                                };
                                pci_out {
                                        lantiq,groups = "gnt1";
                                        lantiq,function = "pci";
                                        lantiq,pull = <2>;
                                        lantiq,output = <0>;
                                };
                                pci_out {
                                        lantiq,groups = "gnt1";
                                        lantiq,function = "pci";
+                                       lantiq,open-drain = <1>;
                                        lantiq,output = <1>;
                                };
                                pci_rst {
                                        lantiq,pins = "io21";
                                        lantiq,output = <1>;
                                };
                                pci_rst {
                                        lantiq,pins = "io21";
-                                       lantiq,pull = <2>;
+                                       lantiq,open-drain = <1>;
                                        lantiq,output = <1>;
                                };
                                leds {
                                        lantiq,pins = "io3", "io5", "io6", "io8";
                                        lantiq,output = <1>;
                                };
                                leds {
                                        lantiq,pins = "io3", "io5", "io6", "io8";
+                                       lantiq,open-drain = <1>;
                                        lantiq,output = <1>;
                                };
                                        lantiq,output = <1>;
                                };
+                               buttons {
+                                       lantiq,pins = "io11", "io12", "io13", "io28";
+                                       lantiq,pull = <2>;
+                                       lantiq,output = <0>;
+                               };
                        };
                };
 
                        };
                };
 
                };
 
                etop@E180000 {
                };
 
                etop@E180000 {
-                       phy-mode = "rmii";
+                       phy-mode = "mii";
                };
 
                pci@E105400 {
                };
 
                pci@E105400 {
index 797969a3b0651713f6f663bcae5786109a51da8f..4528741ea0ac7827bbf544223972829158a2d1e9 100644 (file)
@@ -116,7 +116,7 @@ $(eval $(call Profile,ARV752DPW))
 
 define Profile/ARV752DPW22
   NAME:=Easybox 803 - ARV752DPW22
 
 define Profile/ARV752DPW22
   NAME:=Easybox 803 - ARV752DPW22
-  PACKAGES:=kmod-usb2 kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+  PACKAGES:=kmod-usb2-pci kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
        kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
        kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
        ltq-adsl-app ppp-mod-pppoa \
        kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
        kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
        ltq-adsl-app ppp-mod-pppoa \