iproute2: refresh patches
authorFelix Fietkau <nbd@openwrt.org>
Mon, 1 Feb 2016 18:04:00 +0000 (18:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 1 Feb 2016 18:04:00 +0000 (18:04 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48613

package/network/utils/iproute2/patches/006-no_sctp.patch
package/network/utils/iproute2/patches/007-no_arpd.patch
package/network/utils/iproute2/patches/008-no_netem.patch
package/network/utils/iproute2/patches/110-extra-ccopts.patch
package/network/utils/iproute2/patches/120-libnetlink-pic.patch
package/network/utils/iproute2/patches/130-missing_include.patch
package/network/utils/iproute2/patches/300-ip_tiny.patch
package/network/utils/iproute2/patches/900-drop_FAILED_POLICY.patch
package/network/utils/iproute2/patches/911-fix_in_h_include.patch

index 4aa988415e80a30c9f1abc008b7bf78c46217a92..6805468d81b388417ff3f3a3c79a2cf4f1af68a8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/ipxfrm.c
 +++ b/ip/ipxfrm.c
 --- a/ip/ipxfrm.c
 +++ b/ip/ipxfrm.c
-@@ -467,7 +467,6 @@ void xfrm_selector_print(struct xfrm_sel
+@@ -470,7 +470,6 @@ void xfrm_selector_print(struct xfrm_sel
        switch (sel->proto) {
        case IPPROTO_TCP:
        case IPPROTO_UDP:
        switch (sel->proto) {
        case IPPROTO_TCP:
        case IPPROTO_UDP:
@@ -8,11 +8,11 @@
        case IPPROTO_DCCP:
        default: /* XXX */
                if (sel->sport_mask)
        case IPPROTO_DCCP:
        default: /* XXX */
                if (sel->sport_mask)
-@@ -1337,7 +1336,6 @@ static int xfrm_selector_upspec_parse(st
+@@ -1341,7 +1340,6 @@ static int xfrm_selector_upspec_parse(st
                switch (sel->proto) {
                case IPPROTO_TCP:
                case IPPROTO_UDP:
 -              case IPPROTO_SCTP:
                case IPPROTO_DCCP:
                switch (sel->proto) {
                case IPPROTO_TCP:
                case IPPROTO_UDP:
 -              case IPPROTO_SCTP:
                case IPPROTO_DCCP:
+               case IPPROTO_IP: /* to allow shared SA for different protocols */
                        break;
                        break;
-               default:
index d33dfe60d9a16010875f97ecc411338639eeee07..94fb197a459a67f4d2f65d62368e4c364aff8f39 100644 (file)
@@ -1,16 +1,15 @@
 --- a/misc/Makefile
 +++ b/misc/Makefile
 --- a/misc/Makefile
 +++ b/misc/Makefile
-@@ -5,9 +5,9 @@
-
+@@ -5,9 +5,9 @@ TARGETS=ss nstat ifstat rtacct lnstat
  include ../Config
  include ../Config
-
 -ifeq ($(HAVE_BERKELEY_DB),y)
 -      TARGETS += arpd
 -endif
 +#ifeq ($(HAVE_BERKELEY_DB),y)
 +#     TARGETS += arpd
 +#endif
 -ifeq ($(HAVE_BERKELEY_DB),y)
 -      TARGETS += arpd
 -endif
 +#ifeq ($(HAVE_BERKELEY_DB),y)
 +#     TARGETS += arpd
 +#endif
-
  ifeq ($(HAVE_SELINUX),y)
  ifeq ($(HAVE_SELINUX),y)
-       LDLIBS += $(shell pkg-config --libs libselinux)
-
+       LDLIBS += $(shell $(PKG_CONFIG) --libs libselinux)
index 232a6ea973a98c480438a67703ab6a768674399e..fce16e02dff335aea09348f44c4fbab0dc1448aa 100644 (file)
@@ -3,10 +3,9 @@
 @@ -41,7 +41,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
  CFLAGS := $(WFLAGS) $(CCOPTS) -I../include $(DEFINES) $(CFLAGS)
  YACCFLAGS = -d -t -v
 @@ -41,7 +41,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
  CFLAGS := $(WFLAGS) $(CCOPTS) -I../include $(DEFINES) $(CFLAGS)
  YACCFLAGS = -d -t -v
-
 -SUBDIRS=lib ip tc bridge misc netem genl tipc man
 +SUBDIRS=lib ip tc bridge misc genl tipc man
 -SUBDIRS=lib ip tc bridge misc netem genl tipc man
 +SUBDIRS=lib ip tc bridge misc genl tipc man
-
  LIBNETLINK=../lib/libnetlink.a ../lib/libutil.a
  LDLIBS += $(LIBNETLINK)
  LIBNETLINK=../lib/libnetlink.a ../lib/libutil.a
  LDLIBS += $(LIBNETLINK)
-
index 611b1bce6130913dfbf63168210857591ce9b070..3cb5a7940060dfcc7c0799242ededd31b13377df 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
 --- a/Makefile
 +++ b/Makefile
-@@ -34,7 +34,7 @@ ADDLIB+=ipx_ntop.o ipx_pton.o
+@@ -34,7 +34,7 @@ HOSTCC = gcc
  DEFINES += -D_GNU_SOURCE
  # Turn on transparent support for LFS
  DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
  DEFINES += -D_GNU_SOURCE
  # Turn on transparent support for LFS
  DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
@@ -8,3 +8,4 @@
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
  WFLAGS := -Wall -Wstrict-prototypes  -Wmissing-prototypes
  WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
  WFLAGS := -Wall -Wstrict-prototypes  -Wmissing-prototypes
  WFLAGS += -Wmissing-declarations -Wold-style-definition -Wformat=2
index 19ccd1a936f871f235561e6787545b1e760bd380..1f397f71b2d85a044207a17925cde07f3c02961c 100644 (file)
@@ -1,11 +1,11 @@
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -4,7 +4,7 @@ ifeq ($(IP_CONFIG_SETNS),y)
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -4,7 +4,7 @@ ifeq ($(IP_CONFIG_SETNS),y)
-       CFLAGS += -DHAVE_SETNS
+       CFLAGS += -DHAVE_SETNS
  endif
  
 -CFLAGS += -fPIC
 +CFLAGS += $(FPIC)
  
  endif
  
 -CFLAGS += -fPIC
 +CFLAGS += $(FPIC)
  
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o \
-       names.o
+ UTILOBJ = utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o \
+       inet_proto.o namespace.o json_writer.o \
index 6dc63e41284bf23f0350a5d3d85cc3a8f9176bc5..88dfd8585f0117fab29850730841b4fbba2f010a 100644 (file)
@@ -5,6 +5,6 @@
  #include <dirent.h>
  #include <limits.h>
 +#include <sys/param.h>
  #include <dirent.h>
  #include <limits.h>
 +#include <sys/param.h>
-
  #include "utils.h"
  #include "namespace.h"
  #include "utils.h"
  #include "namespace.h"
index c0ebfd3ce5c9cf5fc71aa7571a88d96dd208c01c..290adbe5f58055c93a04caf03f36443f748a1d17 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ip/Makefile
 +++ b/ip/Makefile
 --- a/ip/Makefile
 +++ b/ip/Makefile
-@@ -16,6 +16,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
+@@ -17,6 +17,13 @@ ifeq ($(IP_CONFIG_SETNS),y)
        CFLAGS += -DHAVE_SETNS
  endif
  
        CFLAGS += -DHAVE_SETNS
  endif
  
@@ -14,7 +14,7 @@
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
  TARGETS=ip rtmon
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
  TARGETS=ip rtmon
-@@ -43,7 +50,7 @@ else
+@@ -44,7 +51,7 @@ else
  
  ip: static-syms.o
  static-syms.o: static-syms.h
  
  ip: static-syms.o
  static-syms.o: static-syms.h
@@ -70,7 +70,7 @@
  };
 --- a/lib/utils.c
 +++ b/lib/utils.c
  };
 --- a/lib/utils.c
 +++ b/lib/utils.c
-@@ -675,6 +675,7 @@ const char *rt_addr_n2a(int af, int len,
+@@ -710,6 +710,7 @@ const char *rt_addr_n2a(int af, int len,
                return inet_ntop(af, addr, buf, buflen);
        case AF_MPLS:
                return mpls_ntop(af, addr, buf, buflen);
                return inet_ntop(af, addr, buf, buflen);
        case AF_MPLS:
                return mpls_ntop(af, addr, buf, buflen);
@@ -78,7 +78,7 @@
        case AF_IPX:
                return ipx_ntop(af, addr, buf, buflen);
        case AF_DECnet:
        case AF_IPX:
                return ipx_ntop(af, addr, buf, buflen);
        case AF_DECnet:
-@@ -683,6 +684,7 @@ const char *rt_addr_n2a(int af, int len,
+@@ -718,6 +719,7 @@ const char *rt_addr_n2a(int af, int len,
                memcpy(dna.a_addr, addr, 2);
                return dnet_ntop(af, &dna, buf, buflen);
        }
                memcpy(dna.a_addr, addr, 2);
                return dnet_ntop(af, &dna, buf, buflen);
        }
@@ -89,7 +89,7 @@
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -4,6 +4,10 @@ ifeq ($(IP_CONFIG_SETNS),y)
-       CFLAGS += -DHAVE_SETNS
+       CFLAGS += -DHAVE_SETNS
  endif
  
 +ifeq ($(IP_CONFIG_TINY),y)
  endif
  
 +ifeq ($(IP_CONFIG_TINY),y)
@@ -98,4 +98,4 @@
 +
  CFLAGS += $(FPIC)
  
 +
  CFLAGS += $(FPIC)
  
- UTILOBJ=utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o inet_proto.o namespace.o \
+ UTILOBJ = utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o \
index f5d2dfe9b9bd34906f3210d6ddcb69c7085c3c9b..ff2e0aa1ee73f8ac2b844b5d384ea4889203729d 100644 (file)
@@ -24,7 +24,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
  
 --- a/include/linux/rtnetlink.h
 +++ b/include/linux/rtnetlink.h
  
 --- a/include/linux/rtnetlink.h
 +++ b/include/linux/rtnetlink.h
-@@ -208,6 +208,7 @@ enum {
+@@ -210,6 +210,7 @@ enum {
        RTN_THROW,              /* Not in this table            */
        RTN_NAT,                /* Translate this address       */
        RTN_XRESOLVE,           /* Use external resolver        */
        RTN_THROW,              /* Not in this table            */
        RTN_NAT,                /* Translate this address       */
        RTN_XRESOLVE,           /* Use external resolver        */
index cce086c3e5d7b526dabc242cce3c8be513e77695..42a7b24bbbd3368f048468d5d2f9057d6c91990d 100644 (file)
@@ -1,16 +1,16 @@
 --- a/include/linux/in.h
 +++ b/include/linux/in.h
 @@ -15,6 +15,7 @@
 --- a/include/linux/in.h
 +++ b/include/linux/in.h
 @@ -15,6 +15,7 @@
-  *             as published by the Free Software Foundation; either version
-  *             2 of the License, or (at your option) any later version.
+  *            as published by the Free Software Foundation; either version
+  *            2 of the License, or (at your option) any later version.
   */
 +#ifndef _NETINET_IN_H
  #ifndef _LINUX_IN_H
  #define _LINUX_IN_H
   */
 +#ifndef _NETINET_IN_H
  #ifndef _LINUX_IN_H
  #define _LINUX_IN_H
-
 @@ -297,3 +298,4 @@ struct sockaddr_in {
 @@ -297,3 +298,4 @@ struct sockaddr_in {
-
-
  #endif /* _LINUX_IN_H */
 +#endif /* _NETINET_IN_H */
 --- a/include/linux/in6.h
  #endif /* _LINUX_IN_H */
 +#endif /* _NETINET_IN_H */
 --- a/include/linux/in6.h