x86: add modern network modules to Generic target
authorAlberto Bursi <alberto.bursi@outlook.it>
Sun, 14 Jul 2019 01:11:00 +0000 (03:11 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sat, 20 Jul 2019 20:58:08 +0000 (22:58 +0200)
Many Atom-based embedded/industrial x86 boards can't run 64bit operating
systems due to either processor or board firmware limitations, but they
have modern interfaces (PCIe) or have modern Intel gigabit controllers
onboard.  With the current default package selection for x86 Generic
target their network won't work.

Add the modern gigabit network modules needed or most likely going to be
used as add-in cards, similar to what is the list on x86_64 target.

Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
[fixed whitespace issue]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit bb27cde2579b0273c464e5ccd3dda7d14e84fd23)

target/linux/x86/generic/profiles/000-Generic.mk

index 90f989a91de33164339f1d25aa574a18a337c5ff..4760767eee14c022d5c7c3ad5b51c1162dcc5004 100644 (file)
@@ -7,7 +7,8 @@
 
 define Profile/Generic
   NAME:=Generic
-  PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
+  PACKAGES:=kmod-e1000e kmod-igb kmod-bnx2 \
+       kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
        kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
        kmod-via-rhine kmod-via-velocity
 endef