base-files: abort sysupgrade if file specified with --restore-config is not found
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 31 Jul 2013 14:10:34 +0000 (14:10 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 31 Jul 2013 14:10:34 +0000 (14:10 +0000)
SVN-Revision: 37624

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index dcae920f9acb59b3a52b3091bab074450eeb0e6e..93941b9155006aee4a550c2827c3aeabcd0053fb 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=144
+PKG_RELEASE:=145
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 49c34b80732b84a32df96cfd71a6b4791cd2fe83..f6b628e96ef6123ac4c6045a28270396059bf6bd 100755 (executable)
@@ -140,7 +140,12 @@ if [ -n "$CONF_BACKUP" ]; then
        exit $?
 fi
 
-if [ -f "$CONF_RESTORE" ] || [ "$CONF_RESTORE" = "-" ]; then
+if [ -n "$CONF_RESTORE" ]; then
+       if [ "$CONF_RESTORE" != "-" ] && [ ! -f "$CONF_RESTORE" ]; then
+               echo "Backup archive '$CONF_RESTORE' not found."
+               exit 1
+       fi
+
        [ "$VERBOSE" -gt 1 ] && TAR_V="v" || TAR_V=""
        tar -C / -x${TAR_V}zf "$CONF_RESTORE"
        exit $?