firewall: prevent excessive uci state data aggregation (#9152)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 20 Apr 2011 11:49:09 +0000 (11:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 20 Apr 2011 11:49:09 +0000 (11:49 +0000)
SVN-Revision: 26740

package/firewall/Makefile
package/firewall/files/lib/core_interface.sh

index ea407f081bb1c49b47941ee0a8b8f99d76349961..829719c279151ba9070491826021036d4df0d46d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=24
+PKG_RELEASE:=25
 
 include $(INCLUDE_DIR)/package.mk
 
index ed6a4b150fd9414f0a229903445d86b30fc1f375..bc9eb96ddedc2faa349ccc40d72fa63203229a00 100644 (file)
@@ -8,6 +8,7 @@ fw__uci_state_add() {
        val="${val// $item / }"
        val="${val# }"
        val="${val% }"
+       uci_revert_state firewall core $var
        uci_set_state firewall core $var "${val:+$val }$item"
 }
 
@@ -19,6 +20,7 @@ fw__uci_state_del() {
        val="${val// $item / }"
        val="${val# }"
        val="${val% }"
+       uci_revert_state firewall core $var
        uci_set_state firewall core $var "$val"
 }