ath79: add tl-wr2543-v1 support
authorLucian Cristian <lucian.cristian@gmail.com>
Wed, 20 Jun 2018 22:02:10 +0000 (01:02 +0300)
committerJohn Crispin <john@phrozen.org>
Tue, 26 Jun 2018 06:57:26 +0000 (08:57 +0200)
to switch between wlan leds we need a userspace implementation

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/config-4.14
target/linux/ath79/dts/ar7242_tl-wr2543-v1.dts [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk

index 743b877aba92d8184cdf1cb77452eb34fb7e1eb2..d978c3441e3b178c10dbda511a8eb0e864103716 100755 (executable)
@@ -70,6 +70,10 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan" "6@eth0"
                ;;
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5:wan" "6@eth0"
                ;;
+       "tplink,tl-wr2543-v1")
+               ucidef_add_switch "switch0" \
+                       "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "9@eth0"
+               ;;
        "netgear,wndr3800")
                ucidef_set_interfaces_lan_wan "eth0" "eth1"
                ucidef_add_switch "switch0" \
        "netgear,wndr3800")
                ucidef_set_interfaces_lan_wan "eth0" "eth1"
                ucidef_add_switch "switch0" \
index 5b22b1544f8189e50f6bce3e95bcd4b5c9884749..7023fa5e587ccbb09ca9619b17ee81fc854b8529 100644 (file)
@@ -57,6 +57,7 @@ case "$FIRMWARE" in
        "netgear,wnr612-v2"|\
        "on,n150r"|\
        "tplink,tl-wr740n-v2"|\
        "netgear,wnr612-v2"|\
        "on,n150r"|\
        "tplink,tl-wr740n-v2"|\
+       "tplink,tl-wr2543-v1"|\
        "ubnt,unifi")
                ath9k_eeprom_extract "art" 4096 2048
                ;;
        "ubnt,unifi")
                ath9k_eeprom_extract "art" 4096 2048
                ;;
index 0e24582cc790e4dd4318ba18ef853a91110f6634..01d259572a9f34323255fe35c5488328696c278b 100644 (file)
@@ -205,6 +205,7 @@ CONFIG_RESET_CONTROLLER=y
 CONFIG_RTL8366RB_PHY=y
 CONFIG_RTL8366S_PHY=y
 CONFIG_RTL8366_SMI=y
 CONFIG_RTL8366RB_PHY=y
 CONFIG_RTL8366S_PHY=y
 CONFIG_RTL8366_SMI=y
+CONFIG_RTL8367_PHY=y
 # CONFIG_SCHED_INFO is not set
 # CONFIG_SCSI_DMA is not set
 # CONFIG_SERIAL_8250_FSL is not set
 # CONFIG_SCHED_INFO is not set
 # CONFIG_SCSI_DMA is not set
 # CONFIG_SERIAL_8250_FSL is not set
diff --git a/target/linux/ath79/dts/ar7242_tl-wr2543-v1.dts b/target/linux/ath79/dts/ar7242_tl-wr2543-v1.dts
new file mode 100644 (file)
index 0000000..0934fe0
--- /dev/null
@@ -0,0 +1,186 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar7242.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr2543-v1", "qca,ar7242";
+       model = "TP-LINK TL-WR2543N/ND";
+
+       aliases {
+               led-status = &system;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x4000000>;
+       };
+
+       extosc: ref {
+               compatible = "fixed-clock";
+               #clock-cells = <0>;
+               clock-frequency = <40000000>;
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               system: wps {
+                       label = "tplink:green:wps";
+                       gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               usb {
+                       label = "tplink:green:usb";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&hub_port>;
+                       linux,default-trigger = "usbport";
+               };
+       };
+
+       ath9k-leds {
+               compatible = "gpio-leds";
+
+               wlan2g {
+                       label = "tplink:green:wlan2g";
+                       gpios = <&ath9k 0 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wlan5g {
+                       label = "tplink:green:wlan5g";
+                       gpios = <&ath9k 1 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy0tpt";
+               };
+
+       };
+
+       rtl8367 {
+               compatible = "realtek,rtl8367";
+               gpio-sda = <&gpio 1 GPIO_ACTIVE_HIGH>;
+               gpio-sck = <&gpio 6 GPIO_ACTIVE_HIGH>;
+               realtek,extif0 = <1 0 1 1 1 1 1 1 2>;
+
+               mdio-bus {
+                       status = "okay";
+
+                       phy0: ethernet-phy@0 {
+                               reg = <0>;
+                       };
+               };
+       };
+};
+
+&pll {
+       clocks = <&extosc>;
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot:  partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x020000 0x7d0000>;
+                       };
+
+                       partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb {
+       status = "okay";
+
+       hub_port: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&pcie {
+       status = "okay";
+
+       ath9k: wifi@0 {
+               reg = <0x0000 0 0 0 0>;
+               #gpio-cells = <2>;
+               gpio-controller;
+               qca,no-eeprom;
+               mtd-mac-address = <&uboot 0x1fc00>;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-mode = "rgmii";
+       mtd-mac-address = <&uboot 0x1fc00>;
+
+       phy-handle = <&phy0>;
+       fixed-link {
+               speed = <1000>;
+               full-duplex;
+       };
+};
index 467e2c4c42c54db9cae587f8ecb087ba29a91969..accaf3b68f521f4eea1de35971977fde4874d6fd 100644 (file)
@@ -62,3 +62,16 @@ define Device/tl-wr1043nd-v4
   SUPPORTED_DEVICES := tplink,tl-wr1043nd-v4 tl-wr1043nd-v4
 endef
 TARGET_DEVICES += tl-wr1043nd-v4
   SUPPORTED_DEVICES := tplink,tl-wr1043nd-v4 tl-wr1043nd-v4
 endef
 TARGET_DEVICES += tl-wr1043nd-v4
+
+define Device/tl-wr2543-v1
+  $(Device/tplink-8mlzma)
+  ATH_SOC := ar7242
+  DEVICE_TITLE := TP-LINK TL-WR2543N/ND v1
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+  TPLINK_HWID := 0x25430001
+  IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade -v 3.13.99 | \
+    append-metadata | check-size $$$$(IMAGE_SIZE)
+  IMAGE/factory.bin := append-rootfs | mktplinkfw factory -v 3.13.99
+  SUPPORTED_DEVICES := tplink,tl-wr2543-v1 tl-wr2543-v1
+endef
+TARGET_DEVICES += tl-wr2543-v1