ipq806x: nbg6817: add kmod-fs-ext4 to device packages
authorStefan Lippers-Hollmann <s.l-h@gmx.de>
Thu, 19 Oct 2017 19:40:26 +0000 (21:40 +0200)
committerMathias Kresin <dev@kresin.me>
Fri, 3 Nov 2017 21:59:19 +0000 (22:59 +0100)
The ZyXEL NBG6817 uses an eMMC flash for the rootfs, which is split
into the readonly squashfs and ext4 for the overlay. This adds the
required package to the device packages to allow mounting the overlay
by default.

/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/loop0 on /overlay type ext4 (rw,noatime,data=ordered)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
mountd(pid1040) on /tmp/run/blockd type autofs (rw,relatime,fd=7,pgrp=1,timeout=30,minproto=5,maxproto=5,indirect)

Before this commit, the ext4 based overlayfs could not be mounted,
which left only the tmpfs based/ volatile  emergency overlay in place.

Fixes: https://forum.lede-project.org/t/zyxel-nbg6817-flashing-from-oem/768
Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
target/linux/ipq806x/image/Makefile

index e834b250988cd0d9dbcc5b40edf7b3baadc9ccea..01bdb6580f159b4445b66cc2619a564514771a31 100644 (file)
@@ -220,7 +220,7 @@ define Device/NBG6817
        BLOCKSIZE := 64k
        BOARD_NAME := nbg6817
        DEVICE_TITLE := ZyXEL NBG6817
        BLOCKSIZE := 64k
        BOARD_NAME := nbg6817
        DEVICE_TITLE := ZyXEL NBG6817
-       DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs losetup
+       DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs kmod-fs-ext4 losetup
        $(call Device/ZyXELImage)
 endef
 
        $(call Device/ZyXELImage)
 endef