brcm63xx: add DT support for DSL-2650U
authorJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 00:51:17 +0000 (00:51 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 1 Dec 2014 00:51:17 +0000 (00:51 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43452

target/linux/brcm63xx/dts/dsl-2650u.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/patches-3.14/504-board_dsl_274xb_rev_c.patch
target/linux/brcm63xx/patches-3.14/508-board_hw553.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/profiles/d-link.mk

diff --git a/target/linux/brcm63xx/dts/dsl-2650u.dts b/target/linux/brcm63xx/dts/dsl-2650u.dts
new file mode 100644 (file)
index 0000000..23b3301
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+       model = "D-Link DSL-2650U";
+       compatible = "d-link,dsl-2650u", "brcm,bcm6358";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x7e0000>;
+       };
+
+       nvram@7f0000 {
+               label = "nvram";
+               reg = <0x7f0000 0x010000>;
+       };
+};
index 39dfb0a5167aa6f995cde3afef95be723bffa469..939d8e0681a894c7d16235efe1f50b46d171b06b 100755 (executable)
@@ -208,8 +208,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
        # D-Link DSL-2640B, rev B2
        $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B-B2)
-       # D-Link DSL-2650U
-       $(call Image/Build/CFE,$(1),96358VW2,6358,DSL2650U)
 
        # TP-Link 8900GB
        $(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
@@ -288,6 +286,8 @@ $(eval $(call ImageDTB,CFEDTB,VR3025u,vr-3025u,96368M-1541N,6368,VR-3025u,--pad
 $(eval $(call ImageDTB,CFEDTB,VR3025un,vr-3025un,96368M-1341N,6368,VR-3025un,--pad 4))
 # Comtrend WAP-5813n
 $(eval $(call ImageDTB,CFEDTB,WAP5813n,wap-5813n,96369R-1231N,6368,WAP-5813n,--pad 4))
+# D-Link DSL-2650U
+$(eval $(call ImageDTB,CFEDTB,DSL2650U,dsl-2650u,96358VW2,6358,DSL2650U))
 # D-Link DSL-2740B/DSL-2741B, rev C2
 $(eval $(call ImageDTB,CFEDTB,DSL274XB_C,dsl-274xb-c,96358GW,6358,DSL274XB-C2))
 # D-Link DSL-2740B/DSL-2741B, rev C3
index a602017d38b26a702a77607ef02815a6bbe6e774..a38fca589fc76fb2ae5db1b4d0c00707e6dda95e 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,44 @@ static const struct board_info __initcon
+@@ -736,6 +736,45 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -45,6 +45,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +      { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
 +      { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
 +      { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
++      { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
 +      { .compatible = "pirelli,a226g", .data = &board_DWVS0, },
 +      { .compatible = "pirelli,a226m", .data = &board_DWVS0, },
 +      { .compatible = "pirelli,a226m-fwb", .data = &board_DWVS0, },
index 791db6973daedfd61490a86f1fe989f0120320a9..d1433607e6e1e71a7c4d08576ee2441016fdf7ed 100644 (file)
@@ -75,6 +75,6 @@
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
 +      { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
+       { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "pirelli,a226g", .data = &board_DWVS0, },
        { .compatible = "pirelli,a226m", .data = &board_DWVS0, },
-       { .compatible = "pirelli,a226m-fwb", .data = &board_DWVS0, },
index f45371e0f91627d9150f4b3979b5f7463962fd21..e08550d7e094bdf70dab43e0b248916618994576 100644 (file)
@@ -93,9 +93,9 @@
  };
  
 @@ -1538,6 +1616,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
+       { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
 +      { .compatible = "huawei,hg553", .data = &board_HW553, },
        { .compatible = "pirelli,a226g", .data = &board_DWVS0, },
        { .compatible = "pirelli,a226m", .data = &board_DWVS0, },
index 6f60088035cbf1e5979cadd77a0985a7970fbed7..eef548dab7abdb7d6ff6123bd326147f6064fb9c 100644 (file)
@@ -83,9 +83,9 @@
  
  #ifdef CONFIG_BCM63XX_CPU_6368
 @@ -2548,6 +2616,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
+       { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
 +      { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
        { .compatible = "pirelli,a226g", .data = &board_DWVS0, },
index 69c2fc8639a9ee41349290944164f9ca10b37794..4bfefb9ee470f8d4987189d05a9699ebb972021d 100644 (file)
@@ -5,6 +5,16 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DSL2650U
+  NAME:=D-Link DSL-2650U
+  PACKAGES:=kmod-b43 wpad-mini\
+       kmod-usb2 kmod-usb-ohci
+endef
+define Profile/DSL2650U/Description
+  Package set optimized for DSL-2650U.
+endef
+$(eval $(call Profile,DSL2650U))
+
 define Profile/DSL274XB_C
   NAME:=D-Link DSL-2740B/DSL-2741B rev C2/C3
   PACKAGES:=kmod-b43 wpad-mini