tools/qemu: use default host configure rule ; set appropriate vars & args
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 9 Jan 2017 12:46:18 +0000 (14:46 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 18 Jan 2017 07:54:58 +0000 (08:54 +0100)
Admittedly, this is my own OCD wanting to get rid of this.

Because I tried (a while back to upgrade QEMU to a newer version),
and (during that attempt) I tried to get rid of this.

Tested on Linux & Mac.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
tools/qemu/Makefile

index 2d954e47aabe2f314f4ca81a9511d79499669fdb..783d0f9fad630a78f7fa12225b689eabdc6a4544 100644 (file)
@@ -18,15 +18,13 @@ include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CFLAGS += -I$(STAGING_DIR_HOST)/include/e2fsprogs
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-               CFLAGS="$(HOST_CFLAGS)" \
-               LDFLAGS="$(HOST_LDFLAGS)" \
-               $(HOST_CONFIGURE_CMD) \
-               --extra-cflags="$(HOST_CFLAGS)" \
-               --enable-uuid \
-       )
-endef
+HOST_CONFIGURE_VARS := \
+       CFLAGS="$(HOST_CFLAGS)" \
+       LDFLAGS="$(HOST_LDFLAGS)"
+
+HOST_CONFIGURE_ARGS := \
+       --extra-cflags="$(HOST_CFLAGS)" \
+       --enable-uuid
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) qemu-img