rules.mk: add FILECMD variable
authorMichael Pratt <mcpratt@pm.me>
Tue, 14 Mar 2023 09:10:50 +0000 (05:10 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 26 Mar 2023 22:41:50 +0000 (00:41 +0200)
Some packages using Libtool have the possibility
of using this environment variable if set,
instead of the direct command for "file" using PATH,
or the need to patch a hard-coded path.

This is a new feature of Libtool 2.4.7

Ref: bf261073d ("tools/libtool: bump to 2.4.7")
Signed-off-by: Michael Pratt <mcpratt@pm.me>
rules.mk

index a2f5bcca4b0d0b2c9c3b749eddd5628458307742..57d7995d4fa8feecba752b92b32cf00091486e12 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -252,6 +252,7 @@ TARGET_NM:=$(TARGET_CROSS)gcc-nm
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_CXX:=$(TARGET_CROSS)g++
 KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
+FILECMD:=$(STAGING_DIR_HOST)/bin/file
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 ESED:=$(STAGING_DIR_HOST)/bin/sed -E -i -e
 MKHASH:=$(STAGING_DIR_HOST)/bin/mkhash