lldpd: disable xml explicitly
authorJohn Crispin <john@openwrt.org>
Sun, 31 May 2015 17:46:09 +0000 (17:46 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 31 May 2015 17:46:09 +0000 (17:46 +0000)
This prevents auto-detection of libxml2 and thus the error:
Package lldpd is missing dependencies for the following libraries:
libxml2.so.2

Preventing a dependency to libxml2 is preferred, since libxml2
would be a out-of-(core-)tree dependency.

Reported-by: Buildbot
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 45859

package/network/services/lldpd/Makefile

index 69f70221a985db0b8efd03670ce748172bd693f3..cccb9ba5d771d6844efa69df9580f9f26282c146 100644 (file)
@@ -93,6 +93,7 @@ CONFIGURE_ARGS += \
        --with-readline=no \
        --with-embedded-libevent=no \
        --disable-hardening \
+       --without-xml \
        $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
        $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
        $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \