bcm4908img: detect Linksys images
authorRafał Miłecki <rafal@milecki.pl>
Fri, 10 Sep 2021 14:34:48 +0000 (16:34 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Mon, 13 Dec 2021 13:33:06 +0000 (14:33 +0100)
Linksys uses an extra 0x100 bytes long tail for BCM4908 images.

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit c4d5e60f6115b9a97318774533ea764bf938c2a9)

package/utils/bcm4908img/Makefile
package/utils/bcm4908img/src/bcm4908img.c

index ff504a807872c9f0015f4d5cefdda90922c5d22e..fbb91fba73c60c509507d3f6571d28b1b374dcf3 100644 (file)
@@ -3,7 +3,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bcm4908img
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_FLAGS:=nonshared
 
index f2023ced9f9ed49b5273d9a0f28c1dea7f21093f..240fe895d95e26e313d1acc8c22255e7d4be2427 100644 (file)
@@ -77,6 +77,7 @@ struct bcm4908img_tail {
  * 4. padding  ├─ firmware
  * 5. rootfs  ─┘
  * 6. BCM4908 tail
+ * 7. (Optional) vendor tail
  */
 struct bcm4908img_info {
        size_t cferom_offset;
@@ -249,6 +250,16 @@ struct chk_header {
        char board_id[0];
 };
 
+struct linksys_tail {
+       char magic[9];
+       uint8_t version[8];
+       char model[15];
+       uint32_t crc32;
+       uint8_t padding[9];
+       uint8_t signature[16];
+       uint8_t reserved[192];
+};
+
 static bool bcm4908img_is_all_ff(const void *buf, size_t length)
 {
        const uint8_t *in = buf;
@@ -264,6 +275,7 @@ static bool bcm4908img_is_all_ff(const void *buf, size_t length)
 
 static int bcm4908img_parse(FILE *fp, struct bcm4908img_info *info) {
        struct bcm4908img_tail *tail = &info->tail;
+       struct linksys_tail *linksys;
        struct chk_header *chk;
        struct stat st;
        uint8_t buf[1024];
@@ -297,6 +309,16 @@ static int bcm4908img_parse(FILE *fp, struct bcm4908img_info *info) {
        if (be32_to_cpu(chk->magic) == 0x2a23245e)
                info->cferom_offset = be32_to_cpu(chk->header_len);
 
+       fseek(fp, -sizeof(buf), SEEK_END);
+       if (fread(buf, 1, sizeof(buf), fp) != sizeof(buf)) {
+               fprintf(stderr, "Failed to read file header\n");
+               return -EIO;
+       }
+       linksys = (void *)(buf + sizeof(buf) - sizeof(*linksys));
+       if (!memcmp(linksys->magic, ".LINKSYS.", sizeof(linksys->magic))) {
+               info->tail_offset -= sizeof(*linksys);
+       }
+
        /* Offsets */
 
        for (info->bootfs_offset = info->cferom_offset;