fix ccache build (#1415)
authorFelix Fietkau <nbd@openwrt.org>
Tue, 27 Feb 2007 23:44:04 +0000 (23:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 27 Feb 2007 23:44:04 +0000 (23:44 +0000)
SVN-Revision: 6412

toolchain/ccache/Makefile

index 348aed0fced18991f70015bbe79712fb87e8073a..e8e85b442afc04f39c6852d44e5e1112ea2d247e 100644 (file)
@@ -19,24 +19,31 @@ PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 
-ifneq ($(shell which ccache),)
-  define Build/Configure
-       $(call Build/Configure/Default)
-  endef
-
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
   define Build/Compile
-       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
+       $(MAKE) CC="$(HOSTCC)" -C $(PKG_BUILD_DIR)
   endef
 
   define Build/Install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(STAGING_DIR)" \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(STAGING_DIR)" \
                install
   endef
 
   define Build/Clean
-       $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+       -$(MAKE) -C $(PKG_BUILD_DIR) uninstall
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Clean/Default)
+  endef
+else
+  define Build/Prepare
+  endef
+  define Build/Configure
+  endef
+  define Build/Compile
+  endef
+  define Build/Clean
   endef
 endif
+
 $(eval $(call HostBuild))