build/prereq: merge ifndef IB block together
authorPaul Spooren <mail@aparcar.org>
Wed, 30 Dec 2020 04:19:08 +0000 (18:19 -1000)
committerPaul Spooren <mail@aparcar.org>
Thu, 31 Dec 2020 19:33:07 +0000 (09:33 -1000)
Multiple prereq checks are only required within the build system but not
for the ImageBuilder. These checks are excluded by using ifndef IB.

This commit merges the three ifndef IB blocks together.

Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit cc9d5b5a488d3a43068f621a1ef184f06e43bede)

include/prereq-build.mk

index 7504d43a7480033c5a1a30fc35dfc9953250d8d1..1384f27e82081abe2c83bbec04e71617d8d84cbf 100644 (file)
@@ -38,9 +38,7 @@ $(eval $(call TestHostCommand,working-gcc, \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
-endif
 
-ifndef IB
 $(eval $(call SetupHostCommand,g++, \
        Please install the GNU C++ Compiler (g++) 4.8 or later, \
        $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
@@ -53,14 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
-endif
 
-ifndef IB
 $(eval $(call TestHostCommand,ncurses, \
        Please install ncurses. (Missing libncurses.so or ncurses.h), \
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
-endif
+endif # IB
 
 ifeq ($(HOST_OS),Linux)
   zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic