toolchain/insight: Remove from tree
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Mon, 29 May 2017 07:41:15 +0000 (09:41 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 29 May 2017 07:57:18 +0000 (09:57 +0200)
Insight hasn't been touched since 2009 and I can't find any references at
least 6 years back of being used. Ubuntu and Debian removed insight years ago
from their repos so I think we can safely remove this too.

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
toolchain/Config.in
toolchain/Makefile
toolchain/insight/Makefile [deleted file]
toolchain/insight/patches/600-fix-compile-flag-mismatch.patch [deleted file]

index cb645877defc1fd6c2ba7d829ccd54ee5692817d..f6753ad8ba92d64c1a81b687852ad29bdcda9e05 100644 (file)
@@ -276,14 +276,6 @@ config GDB
        help
          Enable if you want to build the gdb.
 
        help
          Enable if you want to build the gdb.
 
-config INSIGHT
-       bool
-       prompt "Build insight-gdb" if TOOLCHAINOPTS
-       select GDB
-       default n
-       help
-         Enable if you want to build insight-gdb.
-
 config USE_GLIBC
        bool
 
 config USE_GLIBC
        bool
 
index 7a9730fd681f3a2f0e385e8966212c246696fae0..409955c23a9c941387c92499f5270d69a973cdd2 100644 (file)
@@ -29,7 +29,7 @@
 curdir:=toolchain
 
 # subdirectories to descend into
 curdir:=toolchain
 
 # subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
 ifdef CONFIG_USE_UCLIBC
   $(curdir)/builddirs += $(LIBC)/utils
 endif
 ifdef CONFIG_USE_UCLIBC
   $(curdir)/builddirs += $(LIBC)/utils
 endif
diff --git a/toolchain/insight/Makefile b/toolchain/insight/Makefile
deleted file mode 100644 (file)
index 63a0e27..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=insight
-PKG_VERSION:=6.8-1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)a.tar.bz2
-PKG_HASH:=51216df73adc4f68c67b60356270d5073f0ff094c1b477ecd96560f49707ea2a
-PKG_SOURCE_URL:=ftp://sourceware.org/pub/insight/releases
-PKG_CAT:=bzcat
-
-include $(INCLUDE_DIR)/toolchain-build.mk
-
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-               gdb_cv_func_sigsetjmp=yes \
-               CFLAGS="-O2" \
-               $(HOST_BUILD_DIR)/configure \
-               --prefix=$(TOOLCHAIN_DIR) \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --enable-threads \
-               --enable-werror=no \
-       );
-endef
-
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
-       mkdir -p $(TOOLCHAIN_DIR)/bin
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/insight $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight
-       ln -fs $(TARGET_CROSS)insight $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-insight
-       strip $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight
-endef
-
-define Host/Clean
-       rm -rf \
-               $(HOST_BUILD_DIR) \
-               $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight \
-               $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-insight
-endef
-
-$(eval $(call HostBuild))
diff --git a/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch b/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch
deleted file mode 100644 (file)
index 13b72bb..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/gdb/gdbserver/configure
-+++ b/gdb/gdbserver/configure
-@@ -1239,7 +1239,7 @@
-       ac_cache_corrupted=: ;;
-     ,);;
-     *)
--      if test "x$ac_old_val" != "x$ac_new_val"; then
-+      if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
-       { echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5
- echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;}
-       { echo "$as_me:$LINENO:   former value:  $ac_old_val" >&5
---- a/gdb/configure
-+++ b/gdb/configure
-@@ -272,7 +272,7 @@
- PACKAGE_BUGREPORT=
- ac_unique_file="main.c"
--ac_subdirs_all="$ac_subdirs_all doc testsuite"
-+ac_subdirs_all="$ac_subdirs_all doc"
- # Factoring default headers for most tests.
- ac_includes_default="\
- #include <stdio.h>
-@@ -3077,7 +3077,7 @@
--subdirs="$subdirs doc testsuite"
-+subdirs="$subdirs doc"
- # Provide defaults for some variables set by the per-host and per-target