ebtables: update to latest git 2018-05-15
authorHans Dedecker <dedeckeh@gmail.com>
Tue, 15 May 2018 12:00:37 +0000 (14:00 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 06:52:44 +0000 (07:52 +0100)
66a9701 ebtables: Fix build errors and warnings
9fff3d5 include: Fix musl libc compatibility
b1cdae8 extensions: Add string filter to ebtables

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
(backported from ac70ac3532fefa78c944d8a26c8df0ca5d88d04e)
(rebased patches)
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/utils/ebtables/Makefile
package/network/utils/ebtables/patches/100-musl_fix.patch
package/network/utils/ebtables/patches/200-fix-extension-init.patch

index baa8f2efed1153e68860edb4218b75909a74ef61..5275c454f64bbdecf8f01b3a958a6827fd86dff7 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ebtables
-PKG_SOURCE_DATE:=2018-04-11
+PKG_SOURCE_DATE:=2018-05-15
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://git.netfilter.org/ebtables
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=2e783b2277665c467138e7685309622456c41db4
-PKG_MIRROR_HASH:=601a41f579f76c8121bb6076ebcf5eb5efddf634ebb5949ec9e983a17e66e689
+PKG_SOURCE_VERSION:=66a97018a31eed416c6a25d051ea172e4d65be1b
+PKG_MIRROR_HASH:=3205285d4e92ab66d75681fd031b6bdc19954198b58dec1d8cbbf64312ebd445
 
 PKG_LICENSE:=GPL-2.0
 
index 3fe5845897c30850a747b1bdc98515f866436481..9528fe4b19235b27c7a142cefec38997a99114d0 100644 (file)
@@ -6,5 +6,5 @@
  #define EBTABLES_U_H
 +#define _NETINET_IF_ETHER_H
  #include <netinet/in.h>
- #include <linux/netfilter_bridge/ebtables.h>
- #include <linux/netfilter/x_tables.h>
+ #include <netinet/ether.h>
+ #include <ebtables.h>
index 52ab175ec229c75f758330a436a9646e3c9a6447..4b202ac57ef775e7fe1739c57d0aa212e49ee48a 100644 (file)
  {
        ebt_register_table(&table);
  }
+--- a/extensions/ebt_string.c
++++ b/extensions/ebt_string.c
+@@ -310,7 +310,7 @@ static struct ebt_u_match string_match =
+       .extra_ops      = opts,
+ };
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+       ebt_register_match(&string_match);
+ }