code to bring in the following for x86: X86_GRUB_ROOTPART: configureable root partiti...
authorTim Yardley <lst@openwrt.org>
Tue, 24 Oct 2006 22:33:23 +0000 (22:33 +0000)
committerTim Yardley <lst@openwrt.org>
Tue, 24 Oct 2006 22:33:23 +0000 (22:33 +0000)
SVN-Revision: 5289

target/image/x86/Config.in
target/image/x86/Makefile

index 88d8d37c3b216a5a5be783b7af5f419a2ce9cf13..2c3e8840ccb93849653fc19f54728bfc81b7a199 100644 (file)
@@ -14,4 +14,17 @@ config X86_GRUB_KERNELPART
        depends X86_GRUB_IMAGES
        default 4
 
+config X86_GRUB_ROOTPART
+    string
+    prompt "Root partition on target device" if X86_GRUB_IMAGES
+    default "/dev/hda2"
+    help
+        The root partition on the final device.  If you don't know, 
+        you probably want the default (/dev/hda2).
 
+config X86_GRUB_BOOTOPTS
+    string
+    prompt "Extra kernel boot options" if X86_GRUB_IMAGES
+    default ""
+    help
+        If you don't know leave it blank
index 086024545396d6a917d31baae7f454690b828606..8c0cde440fbdbd04733d678846865307c9f89b7f 100644 (file)
@@ -25,7 +25,7 @@ ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
   endef
 
   define Image/cmdline/ext2
-    root=/dev/hda2 rootfstype=ext2
+    root=$(CONFIG_X86_GRUB_ROOTPART) rootfstype=ext2 $(CONFIG_X86_GRUB_BOOTOPTS)
   endef
 
   define Image/Build/grub