at91bootstrap: harmonize indent in Makefiles
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 23 Aug 2020 20:32:28 +0000 (22:32 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 25 Aug 2020 17:28:42 +0000 (19:28 +0200)
The indent in Makefiles is mixed, harmonize it where reasonable.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/at91bootstrap/Makefile
package/boot/at91bootstrap/at91bootstrap.mk

index 08fe2a49b05b48e4a89b3a206cc8067594114d3c..b0d466f7b9bb120277b9dbc4ad0d7deb650d30f7 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/linux4sam/at91bootstrap.git
 PKG_SOURCE_VERSION:=d96833a4b6680b237708eb4dc9f10708b9e709d8
 PKG_BUILD_DIR = \
-    $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+       $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
 include at91bootstrap.mk
 include $(INCLUDE_DIR)/package.mk
@@ -118,24 +118,24 @@ define AT91Bootstrap/sama5d2_ptc_eksd_uboot
 endef
 
 AT91BOOTSTRAP_TARGETS := \
-    at91sam9x5eknf_uboot \
-    at91sam9x5eksd_uboot \
-    sama5d2_xplaineddf_uboot \
-    sama5d2_xplaineddf_qspi_uboot \
-    sama5d2_xplainedsd_uboot \
-    sama5d3_xplainednf_uboot \
-    sama5d3_xplainedsd_uboot \
-    sama5d4_xplainednf_uboot_secure \
-    sama5d4_xplaineddf_uboot_secure \
-    sama5d4_xplainedsd_uboot_secure \
-    sama5d27_som1_eksd1_uboot \
-    sama5d27_som1_ekqspi_uboot \
-    sama5d2_ptc_eknf_uboot \
-    sama5d2_ptc_eksd_uboot
+       at91sam9x5eknf_uboot \
+       at91sam9x5eksd_uboot \
+       sama5d2_xplaineddf_uboot \
+       sama5d2_xplaineddf_qspi_uboot \
+       sama5d2_xplainedsd_uboot \
+       sama5d3_xplainednf_uboot \
+       sama5d3_xplainedsd_uboot \
+       sama5d4_xplainednf_uboot_secure \
+       sama5d4_xplaineddf_uboot_secure \
+       sama5d4_xplainedsd_uboot_secure \
+       sama5d27_som1_eksd1_uboot \
+       sama5d27_som1_ekqspi_uboot \
+       sama5d2_ptc_eknf_uboot \
+       sama5d2_ptc_eksd_uboot
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-        CROSS_COMPILE=$(TARGET_CROSS)
+               CROSS_COMPILE=$(TARGET_CROSS)
 endef
 
 $(eval $(call BuildPackage/AT91Bootstrap))
index 60cd8c4d30d501e2b5c7213f20eb1b6342544f80..fe6577f58927f27e738cb77148dc5bf661ff8693 100644 (file)
@@ -5,7 +5,7 @@ PKG_FLAGS:=nonshared
 export GCC_HONOUR_COPTS=s
 
 define Package/at91bootstrap/install/default
-  $(CP) -avL $(PKG_BUILD_DIR)/binaries/at91bootstrap.bin $(1)/
+       $(CP) -avL $(PKG_BUILD_DIR)/binaries/at91bootstrap.bin $(1)/
 endef
 
 Package/at91bootstrap/install = $(Package/at91bootstrap/install/default)
@@ -34,7 +34,7 @@ define Build/AT91Bootstrap/Target
   $(eval $(call AT91Bootstrap/Default,$(1)))
   $(eval $(call AT91Bootstrap/$(1),$(1)))
 
- define Package/at91bootstrap-$(1)
 define Package/at91bootstrap-$(1)
     SECTION:=boot
     CATEGORY:=Boot Loaders
     TITLE:= .$(NAME)
@@ -45,9 +45,9 @@ define Build/AT91Bootstrap/Target
       DEPENDS += @$(TARGET_DEP)
       ifneq ($(BUILD_DEVICES),)
         DEFAULT := y if ($(TARGET_DEP)_Default \
-               $(patsubst %,|| $(TARGET_DEP)_DEVICE_%,$(BUILD_DEVICES)) \
-               $(patsubst %,|| $(patsubst TARGET_%,TARGET_DEVICE_%, \
-           $(TARGET_DEP))_DEVICE_%,$(BUILD_DEVICES)))
+          $(patsubst %,|| $(TARGET_DEP)_DEVICE_%,$(BUILD_DEVICES)) \
+          $(patsubst %,|| $(patsubst TARGET_%,TARGET_DEVICE_%, \
+          $(TARGET_DEP))_DEVICE_%,$(BUILD_DEVICES)))
       endif
     endif
     $(if $(DEFAULT),DEFAULT:=$(DEFAULT))
@@ -61,28 +61,28 @@ endef
 
 define Build/Configure/AT91Bootstrap
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-        $(AT91BOOTSTRAP_CONFIG)_defconfig
+               $(AT91BOOTSTRAP_CONFIG)_defconfig
 endef
 
 
 define Build/Compile/AT91Bootstrap
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-       CROSS_COMPILE=$(TARGET_CROSS) \
-       $(AT91BOOTSTRAP_MAKE_FLAGS)
+               CROSS_COMPILE=$(TARGET_CROSS) \
+               $(AT91BOOTSTRAP_MAKE_FLAGS)
 endef
 
 define BuildPackage/AT91Bootstrap/Defaults
-  Build/Configure/Default = $$$$(Build/Configure/AT91Bootstrap)
-  Build/Compile/Default = $$$$(Build/Compile/AT91Bootstrap)
+       Build/Configure/Default = $$$$(Build/Configure/AT91Bootstrap)
+       Build/Compile/Default = $$$$(Build/Compile/AT91Bootstrap)
 endef
 
 define BuildPackage/AT91Bootstrap
-  $(eval $(call BuildPackage/AT91Bootstrap/Defaults))
-  $(foreach type,$(if $(DUMP),$(AT91BOOTSTRAP_TARGETS),$(BUILD_VARIANT)), \
-    $(eval $(call Build/AT91Bootstrap/Target,$(type)))
-  )
-  $(eval $(call Build/DefaultTargets))
-  $(foreach type,$(if $(DUMP),$(AT91BOOTSTRAP_TARGETS),$(BUILD_VARIANT)), \
-    $(call BuildPackage,at91bootstrap-$(type))
-  )
+       $(eval $(call BuildPackage/AT91Bootstrap/Defaults))
+       $(foreach type,$(if $(DUMP),$(AT91BOOTSTRAP_TARGETS),$(BUILD_VARIANT)), \
+               $(eval $(call Build/AT91Bootstrap/Target,$(type)))
+       )
+       $(eval $(call Build/DefaultTargets))
+       $(foreach type,$(if $(DUMP),$(AT91BOOTSTRAP_TARGETS),$(BUILD_VARIANT)), \
+               $(call BuildPackage,at91bootstrap-$(type))
+       )
 endef