ar71xx: build firmware image for the TL-MR3420 v1 board
authorGabor Juhos <juhosg@openwrt.org>
Mon, 27 Sep 2010 14:54:04 +0000 (14:54 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 27 Sep 2010 14:54:04 +0000 (14:54 +0000)
SVN-Revision: 23138

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index bad87447513db044be78aed080d316efb96ef2e3..890e4b28a857c0765f1ac85b9cc234c4ea27b4a2 100644 (file)
@@ -5,6 +5,17 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR3420V1
+       NAME:=TP-LINK TL-MR3420 v1
+       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR3420V1/Description
+       Package set optimized for the TP-LINK TL-MR3420 v1.
+endef
+
+$(eval $(call Profile,TLMR3420V1))
+
 define Profile/TLWA901NDV1
        NAME:=TP-LINK TL-WA901ND v1
        PACKAGES:=kmod-ath9k wpad-mini
index 0c348565ffae0306a3e0d8f1d986d59c6f9af88b..42db6e49432871db0f64e42236225c4f372cba24 100644 (file)
@@ -531,6 +531,10 @@ define Image/Build/Profile/MZKW300NH
        $(call Image/Build/Template/$(fs_64k)/$(1),Planex,mzk-w300nh,board=MZK-W300NH)
 endef
 
+define Image/Build/Profile/TLMR3420V1
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-mr3420-v1,board=TL-MR3420,TL-MR3420v1)
+endef
+
 define Image/Build/Profile/TLWA901NDV1
        $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wa901nd-v1,board=TL-WA901ND,TL-WA901NDv1)
 endef
@@ -619,6 +623,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/PB92,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
+       $(call Image/Build/Profile/TLMR3420V1,$(1))
        $(call Image/Build/Profile/TLWA901NDV1,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))