ltq-tapi/vmmc were build on none lantiq targets due to bad builddepends of pjsip
authorJohn Crispin <john@openwrt.org>
Wed, 6 Jul 2011 19:02:27 +0000 (19:02 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 6 Jul 2011 19:02:27 +0000 (19:02 +0000)
SVN-Revision: 27498

package/ltq-tapi/Makefile
package/ltq-vmmc/Makefile
package/pjsip/Makefile

index 64d7defaf371ed8e25b5a7922edbe9fffa90ea86..ecaac2eeb457044d291329652b2ba6c71b66d520 100644 (file)
@@ -60,12 +60,10 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-ifdef CONFIG_TARGET_lantiq
-  define Build/InstallDev
+define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/drv_tapi
        $(CP) --dereference $(PKG_BUILD_DIR)/include/* $(1)/usr/include/drv_tapi
        (cd $(1)/usr/include/drv_tapi && ln -s . include && ln -s ../ifxos/ifx_types.h .)
-  endef
-endif
+endef
 
 $(eval $(call KernelPackage,ltq-tapi))
index 8ca4e2398f0dbfd8985194cc5d93cd8525c9ae1c..51c33f57ea5639044de2e1587898c940ee16d170 100644 (file)
@@ -143,20 +143,18 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-ifdef CONFIG_TARGET_lantiq
-  define Build/InstallDev
+define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        mkdir -p $(1)/usr/include/drv_vmmc
        $(CP) -v --dereference $(PKG_BUILD_DIR)/include/* $(1)/usr/include/drv_vmmc
        (cd $(1)/usr/include/drv_vmmc && ln -snf . include)
-  endef
+endef
 
-  define KernelPackage/ltq-vmmc/install
+define KernelPackage/ltq-vmmc/install
        $(INSTALL_DIR) $(1)/etc/init.d $(1)/$(FW_DIR)
        $(INSTALL_BIN) ./files/vmmc.init $(1)/etc/init.d/vmmc
        $(CP) $(PKG_BUILD_DIR)/firmware/$(FW_SOURCE) $(1)/$(FW_DIR)/$(FW_TARGET)
        $(CP) $(PKG_BUILD_DIR)/coef/$(COEF_SRC) $(1)/$(FW_DIR)/$(COEF_TARGET)
-  endef
-endif
+endef
 
 $(eval $(call KernelPackage,ltq-vmmc))
index 4f385723aba32830dc86dc63c77e92b88a456102..42db149baf3f313732af546c6512b6da7dd6ea17 100644 (file)
@@ -66,7 +66,7 @@ EXTRA_CFLAGS:=-I$(STAGING_DIR)/usr/include/drv_tapi -I$(STAGING_DIR)/usr/include
 endif
 
 Package/pjsip-oss=$(call Package/pjsip-template,oss,)
-Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +kmod-ltq-tapi +kmod-ltq-vmmc)
+Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +TARGET_lantiq:kmod-ltq-tapi +TARGET_lantiq:kmod-ltq-vmmc)
 
 define Build/Prepare
        $(PKG_UNPACK)