ar71xx: create profile and build image for the OpenMesh MR900 board
authorJohn Crispin <john@openwrt.org>
Fri, 14 Nov 2014 16:54:50 +0000 (16:54 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 14 Nov 2014 16:54:50 +0000 (16:54 +0000)
Signed-off-by: Sven Eckelmann <sven@open-mesh.com>
SVN-Revision: 43264

target/linux/ar71xx/generic/profiles/openmesh.mk
target/linux/ar71xx/image/Makefile

index c8846de638b9dcdf7a109971d22f130248c8bf9f..6f714d5f3f280eeaaeb308983c7c9a7b33f557d1 100644 (file)
@@ -38,6 +38,17 @@ endef
 
 $(eval $(call Profile,MR600))
 
+define Profile/MR900
+        NAME:=OpenMesh MR900
+        PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR900/Description
+        Package set optimized for the OpenMesh MR900.
+endef
+
+$(eval $(call Profile,MR900))
+
 define Profile/OPENMESH
        NAME:=OpenMesh products
        PACKAGES:=kmod-ath9k om-watchdog
index 8ab68f0e17d66a9436051566631cb24e1d97b66a..749f11f8e698cb3f3fe8f6c2b6cf5abc4998e7b9 100644 (file)
@@ -1173,6 +1173,7 @@ $(eval $(call SingleProfile,Netgear,64kraw,WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,11
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5P,om5p,,,,OM5P))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
+$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR900,mr900,,,,MR900))
 
 $(eval $(call SingleProfile,PB4X,128k,ALL0305,all0305,ALL0305,ttyS0,115200))
 $(eval $(call SingleProfile,PB4X,128k,EAP7660D,eap7660d,EAP7660D,ttyS0,115200))
@@ -1307,7 +1308,7 @@ $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
 $(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
 $(eval $(call MultiProfile,ARCHERC7, ARCHERC5 ARCHERC7V1 ARCHERC7V2))
 $(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
-$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600))
+$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900))
 $(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
 $(eval $(call MultiProfile,TLMR11U,TLMR11UV1 TLMR11UV2))
 $(eval $(call MultiProfile,TLMR3040,TLMR3040V1 TLMR3040V2))