kernel: bump 4.14 to 4.14.18
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 8 Feb 2018 08:36:38 +0000 (09:36 +0100)
committerStijn Tintel <stijn@linux-ipv6.be>
Thu, 8 Feb 2018 17:43:13 +0000 (18:43 +0100)
Refresh patches.

Remove upstreamed patches:
- apm821xx/010-crypto-gcm-add-GCM-IV-size-constant.patch
- backport/040-crypto-fix-typo-in-KPP-dependency-of-CRYPTO_ECDH.patch
Remove pending-4.14/650-pppoe_header_pad.patch, it is superseded by
upstream commit d32e5740001972c1bb193dd60af02721d047a17e.
Update patch that no longer applies: hack/204-module_strip.patch

Compile-tested: octeon, x86/64.
Runtime-tested: octeon, x86/64.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/010-crypto-gcm-add-GCM-IV-size-constant.patch [deleted file]
target/linux/generic/backport-4.14/040-crypto-fix-typo-in-KPP-dependency-of-CRYPTO_ECDH.patch [deleted file]
target/linux/generic/hack-4.14/204-module_strip.patch
target/linux/generic/hack-4.14/221-module_exports.patch
target/linux/generic/pending-4.14/650-pppoe_header_pad.patch [deleted file]
target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/pending-4.14/834-ledtrig-libata.patch
target/linux/generic/pending-4.14/920-mangle_bootargs.patch

index 05b7a0d9c66002907830c70223c419d4a18e6856..adf9712f004c9c959654ca067cddec76e5c54af4 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .112
 LINUX_VERSION-4.9 = .77
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .112
 LINUX_VERSION-4.9 = .77
-LINUX_VERSION-4.14 = .14
+LINUX_VERSION-4.14 = .18
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.112 = 544b42cbeed022896115c76a18fc97b4507d5b41d7ac0ce1dce9afd6ffd11ecd
 LINUX_KERNEL_HASH-4.9.77 = 7c29bc3fb96f1e23d98f664e786dddd53a1599f56431b9b7fdfba402a4b3705c
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.112 = 544b42cbeed022896115c76a18fc97b4507d5b41d7ac0ce1dce9afd6ffd11ecd
 LINUX_KERNEL_HASH-4.9.77 = 7c29bc3fb96f1e23d98f664e786dddd53a1599f56431b9b7fdfba402a4b3705c
-LINUX_KERNEL_HASH-4.14.14 = 8b96362eb55ae152555980e7193fe2585b487176fb936cc69b8947d7dd32044a
+LINUX_KERNEL_HASH-4.14.18 = 866a94c1c38d923ae18e74b683d7a8a79b674ebdfe7f40f1a3be9a27d39fe354
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/apm821xx/patches-4.14/010-crypto-gcm-add-GCM-IV-size-constant.patch b/target/linux/apm821xx/patches-4.14/010-crypto-gcm-add-GCM-IV-size-constant.patch
deleted file mode 100644 (file)
index 6f0cc60..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From ef780324592dd639e4bfbc5b9bf8934b234b7c99 Mon Sep 17 00:00:00 2001
-From: Corentin LABBE <clabbe.montjoie@gmail.com>
-Date: Tue, 22 Aug 2017 10:08:08 +0200
-Subject: [PATCH] crypto: gcm - add GCM IV size constant
-
-Many GCM users use directly GCM IV size instead of using some constant.
-
-This patch add all IV size constant used by GCM.
-
-Signed-off-by: Corentin Labbe <clabbe.montjoie@gmail.com>
-Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
----
- include/crypto/gcm.h | 8 ++++++++
- 1 file changed, 8 insertions(+)
- create mode 100644 include/crypto/gcm.h
-
---- /dev/null
-+++ b/include/crypto/gcm.h
-@@ -0,0 +1,8 @@
-+#ifndef _CRYPTO_GCM_H
-+#define _CRYPTO_GCM_H
-+
-+#define GCM_AES_IV_SIZE 12
-+#define GCM_RFC4106_IV_SIZE 8
-+#define GCM_RFC4543_IV_SIZE 8
-+
-+#endif
diff --git a/target/linux/generic/backport-4.14/040-crypto-fix-typo-in-KPP-dependency-of-CRYPTO_ECDH.patch b/target/linux/generic/backport-4.14/040-crypto-fix-typo-in-KPP-dependency-of-CRYPTO_ECDH.patch
deleted file mode 100644 (file)
index b3e2720..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-From 4b05f09db650d215632da97f2c25ceba8235102a Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Sun, 26 Nov 2017 00:09:45 +0100
-Subject: [PATCH] crypto: fix typo in KPP dependency of CRYPTO_ECDH
-
-This fixes a typo in the CRYPTO_KPP dependency of CRYPTO_ECDH.
-
-Fixes: 3c4b23901a0c ("crypto: ecdh - Add ECDH software support")
-Cc: <stable@vger.kernel.org> # v4.8+
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- crypto/Kconfig | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/crypto/Kconfig
-+++ b/crypto/Kconfig
-@@ -130,7 +130,7 @@ config CRYPTO_DH
- config CRYPTO_ECDH
-       tristate "ECDH algorithm"
--      select CRYTPO_KPP
-+      select CRYPTO_KPP
-       select CRYPTO_RNG_DEFAULT
-       help
-         Generic implementation of the ECDH algorithm
index 2141cfef92e12e1b0b4d99bb470f0eaa8805af1d..2cbcf0f72ff7af4fc542b21ea70a7b09d30b307f 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1896,6 +1896,13 @@ config TRIM_UNUSED_KSYMS
+@@ -1903,6 +1903,13 @@ config TRIM_UNUSED_KSYMS
  
          If unsure, or if you need to build out-of-tree modules, say N.
  
  
          If unsure, or if you need to build out-of-tree modules, say N.
  
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -2997,9 +2997,11 @@ static struct module *setup_load_info(st
+@@ -3006,9 +3006,11 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,14 +127,14 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3020,6 +3022,7 @@ static int check_modinfo(struct module *
+@@ -3029,6 +3031,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
 +#endif
  
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
 +#endif
  
-       if (get_modinfo(info, "staging")) {
-               add_taint_module(mod, TAINT_CRAP, LOCKDEP_STILL_OK);
+       check_modinfo_retpoline(mod, info);
+
 --- a/scripts/mod/modpost.c
 +++ b/scripts/mod/modpost.c
 @@ -1982,7 +1982,9 @@ static void read_symbols(char *modname)
 --- a/scripts/mod/modpost.c
 +++ b/scripts/mod/modpost.c
 @@ -1982,7 +1982,9 @@ static void read_symbols(char *modname)
@@ -158,7 +158,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        buf_printf(b, "\n");
        buf_printf(b, "__visible struct module __this_module\n");
        buf_printf(b, "__attribute__((section(\".gnu.linkonce.this_module\"))) = {\n");
        buf_printf(b, "\n");
        buf_printf(b, "__visible struct module __this_module\n");
        buf_printf(b, "__attribute__((section(\".gnu.linkonce.this_module\"))) = {\n");
-@@ -2161,16 +2165,20 @@ static void add_header(struct buffer *b,
+@@ -2161,24 +2165,30 @@ static void add_header(struct buffer *b,
  
  static void add_intree_flag(struct buffer *b, int is_intree)
  {
  
  static void add_intree_flag(struct buffer *b, int is_intree)
  {
@@ -168,6 +168,16 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +#endif
  }
  
 +#endif
  }
  
+ /* Cannot check for assembler */
+ static void add_retpoline(struct buffer *b)
+ {
++#ifndef CONFIG_MODULE_STRIPPED
+       buf_printf(b, "\n#ifdef RETPOLINE\n");
+       buf_printf(b, "MODULE_INFO(retpoline, \"Y\");\n");
+       buf_printf(b, "#endif\n");
++#endif
+ }
+
  static void add_staging_flag(struct buffer *b, const char *name)
  {
 +#ifndef CONFIG_MODULE_STRIPPED
  static void add_staging_flag(struct buffer *b, const char *name)
  {
 +#ifndef CONFIG_MODULE_STRIPPED
@@ -179,7 +189,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  /**
  }
  
  /**
-@@ -2269,11 +2277,13 @@ static void add_depends(struct buffer *b
+@@ -2277,11 +2287,13 @@ static void add_depends(struct buffer *b
  
  static void add_srcversion(struct buffer *b, struct module *mod)
  {
  
  static void add_srcversion(struct buffer *b, struct module *mod)
  {
@@ -193,7 +203,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
  
  static void write_if_changed(struct buffer *b, const char *fname)
  }
  
  static void write_if_changed(struct buffer *b, const char *fname)
-@@ -2509,7 +2519,9 @@ int main(int argc, char **argv)
+@@ -2518,7 +2530,9 @@ int main(int argc, char **argv)
                add_staging_flag(&buf, mod->name);
                err |= add_versions(&buf, mod);
                add_depends(&buf, mod, modules);
                add_staging_flag(&buf, mod->name);
                err |= add_versions(&buf, mod);
                add_depends(&buf, mod, modules);
index 9fafc9fae2872c447e18dda00ef808f953a97a3d..ad02d0e5335a4d87ca5f84e5ffecca4512835c4f 100644 (file)
@@ -90,7 +90,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __used                                                          \
 --- a/scripts/Makefile.build
 +++ b/scripts/Makefile.build
        __used                                                          \
 --- a/scripts/Makefile.build
 +++ b/scripts/Makefile.build
-@@ -420,7 +420,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
+@@ -426,7 +426,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
  # Linker scripts preprocessor (.lds.S -> .lds)
  # ---------------------------------------------------------------------------
  quiet_cmd_cpp_lds_S = LDS     $@
  # Linker scripts preprocessor (.lds.S -> .lds)
  # ---------------------------------------------------------------------------
  quiet_cmd_cpp_lds_S = LDS     $@
diff --git a/target/linux/generic/pending-4.14/650-pppoe_header_pad.patch b/target/linux/generic/pending-4.14/650-pppoe_header_pad.patch
deleted file mode 100644 (file)
index 3115073..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From: Felix Fietkau <nbd@nbd.name>
-Subject: pppoe: add extra padding for the header (useful for drivers that need headroom)
-
-lede-commit 6517a757ec711fc3354b857e273e2621042f3c7a
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
- drivers/net/ppp/pppoe.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/drivers/net/ppp/pppoe.c
-+++ b/drivers/net/ppp/pppoe.c
-@@ -861,7 +861,7 @@ static int pppoe_sendmsg(struct socket *
-               goto end;
--      skb = sock_wmalloc(sk, total_len + dev->hard_header_len + 32,
-+      skb = sock_wmalloc(sk, total_len + dev->hard_header_len + 32 + NET_SKB_PAD,
-                          0, GFP_KERNEL);
-       if (!skb) {
-               error = -ENOMEM;
-@@ -869,7 +869,7 @@ static int pppoe_sendmsg(struct socket *
-       }
-       /* Reserve space for headers. */
--      skb_reserve(skb, dev->hard_header_len);
-+      skb_reserve(skb, dev->hard_header_len + NET_SKB_PAD);
-       skb_reset_network_header(skb);
-       skb->dev = dev;
index e7fb83cee2886dba1b2f4b2789c3ab1e5edcff3d..7c858ca111b26f80e16b52bba9421e68c82fa274 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4757,6 +4757,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4768,6 +4768,9 @@ static enum gro_result dev_gro_receive(s
        enum gro_result ret;
        int grow;
  
        enum gro_result ret;
        int grow;
  
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (netif_elide_gro(skb->dev))
                goto normal;
  
        if (netif_elide_gro(skb->dev))
                goto normal;
  
-@@ -6227,6 +6230,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -6238,6 +6241,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
                                           &upper_dev->adj_list.lower);
  }
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info)
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info)
-@@ -6342,6 +6387,8 @@ void netdev_upper_dev_unlink(struct net_
+@@ -6353,6 +6398,8 @@ void netdev_upper_dev_unlink(struct net_
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
@@ -100,7 +100,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
-@@ -6912,6 +6959,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6923,6 +6970,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index 8597a936f5377afcc3a680c972f7756248e6aee1..1ceffc5a29414884fbeb1162fdc73a8d0e588087 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5089,6 +5102,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5090,6 +5103,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -5991,6 +6007,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5992,6 +6008,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6012,6 +6031,12 @@ static void ata_host_release(struct devi
+@@ -6013,6 +6032,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6458,7 +6483,23 @@ int ata_host_register(struct ata_host *h
+@@ -6459,7 +6484,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index ec5ec6b521d2847aca58353e52d80b8bb359e63b..b178a24a5cce303c3543882a5e5536ec1e0105c9 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1420,6 +1420,15 @@ config EMBEDDED
+@@ -1427,6 +1427,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.
  
          an embedded system so certain expert options are available
          for configuration.