ramips: add support for belkin F7C027 wemo/homeautomatisation plug
authorJohn Crispin <john@openwrt.org>
Mon, 10 Jun 2013 08:24:50 +0000 (08:24 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 10 Jun 2013 08:24:50 +0000 (08:24 +0000)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 36897

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/F7C027.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/belkin.mk

index 1970ae0bcd0969d6d27d7bd9f24d5c52cfcde3f6..be2fa56faf3cb169cb46444a53d744859aecf0c9 100755 (executable)
@@ -129,6 +129,9 @@ get_status_led() {
        xdxrn502j)
                status_led="xdxrn502j:green:power"
                ;;
+       f7c027)
+               status_led="belkin:orange:status"
+        ;;
        esac
 }
 
index 320e01d9040e6a1711c7c2b572d472e8614e3608..41dabd9f01061d78829a8e02d94e15a1f1bb39a5 100644 (file)
@@ -71,6 +71,7 @@ case "$FIRMWARE" in
        dir-620-a1 | \
        dir-620-d1 | \
        esr-9753 | \
+       f7c027 | \
        fonera20n | \
        rt-n13u | \
        freestation5 | \
index 63af00d031bd0922d6b4c7dd858122add842bfd9..03ae25bcb1134fb8c16907382bf545d9eef95661 100755 (executable)
@@ -91,6 +91,9 @@ ramips_board_detect() {
        *"ESR-9753")
                name="esr-9753"
                ;;
+       *"F7C027")
+               name="f7c027"
+               ;;
        *"F5D8235 v1")
                name="f5d8235-v1"
                ;;
index b2fa0bd9574fb706cc1f12bbaf72c95b997e071f..2d24f182d7ad9616af5e695888b4c210ac46da9a 100755 (executable)
@@ -37,6 +37,7 @@ platform_check_image() {
        dir-620-d1 | \
        dap-1350 | \
        esr-9753 | \
+       f7c027 | \
        fonera20n | \
        rt-n13u | \
        freestation5 | \
diff --git a/target/linux/ramips/dts/F7C027.dts b/target/linux/ramips/dts/F7C027.dts
new file mode 100644 (file)
index 0000000..91d4383
--- /dev/null
@@ -0,0 +1,126 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "F7C027", "ralink,rt5350-soc";
+       model = "Belkin F7C027";
+
+       palmbus@10000000 {
+               sysc@0 {
+                       ralink,pinmux = "spi", "uartlite", "jtag", "sdram";
+                       ralink,uartmux = "gpio";
+                       ralink,wdtmux = <1>;
+               };
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l12805d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "mx25l12805d";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x770000>;
+                               };
+
+                               partition@7c0000 {
+                                       label = "firmware2";
+                                       reg = <0x7c0000 0x770000>;
+                               };
+
+                               partition@f30000 {
+                                       label = "belkin_settings";
+                                       reg = <0xf30000 0xa0000>;
+                               };
+
+                               partition@fd0000 {
+                                       label = "unknown";
+                                       reg = <0xfd0000 0x10000>;
+                               };
+
+                               partition@fe0000 {
+                                       label = "nvram";
+                                       reg = <0xfe0000 0x10000>;
+                               };
+
+                               partition@ff0000 {
+                                       label = "user_factory";
+                                       reg = <0xff0000 0x10000>;
+                               };
+                       };
+               };
+       };
+
+
+       wmac@10180000 {
+               status = "okay";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               status {
+                       label = "belkin:blue:status";
+                       gpios = <&gpio0 7 1>;
+               };
+               power {
+                       label = "belkin:blue:power";
+                       gpios = <&gpio0 9 1>;
+               };
+               orange {
+                       label = "belkin:orange:status";
+                       gpios = <&gpio0 11 1>;
+               };
+               relay {
+                       label = "belkin:device:relay";
+                       gpios = <&gpio0 13 0>;
+               };
+       };
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               top {
+                       label = "top";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+               power {
+                       label = "power";
+                       gpios = <&gpio0 12 1>;
+                       linux,code = <0x100>;
+               };
+               sensor {
+                       label = "sensor";
+                       gpios = <&gpio0 14 1>;
+                       linux,code = <0x101>;
+               };
+       };
+};
index 5e2d6b7762c2730b7143cd060d5e18bd9ee441f5..ed7932b7053d674a892ad410f4a053359c34f4ae 100644 (file)
@@ -322,6 +322,10 @@ Image/Build/Profile/HW550-3G=$(call BuildFirmware/Default8M/$(1),$(1),hw550-3g,H
 belkin_f5d8235v2_mtd_size=7929856
 Image/Build/Profile/F5D8235V2=$(call BuildFirmware/CustomFlash/$(1),$(1),f5d8235v2,F5D8235_V2,$(belkin_f5d8235v2_mtd_size))
 
+# 0x770000
+belkin_f7c027_mtd_size=7798784
+Image/Build/Profile/F7C027=$(call BuildFirmware/CustomFlash/$(1),$(1),belkinf7c027,F7C027,$(belkin_f7c027_mtd_size))
+
 Image/Build/Profile/FONERA20N=$(call BuildFirmware/Edimax/$(1),$(1),fonera20n,FONERA20N,$(ralink_default_fw_size_8M),RSDK,NL1T,0x50000,0xc0000)
 
 Image/Build/Profile/RT-N13U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n13u,RT-N13U)
@@ -451,6 +455,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/DAP1350,$(1))
        $(call Image/Build/Profile/DAP1350WW,$(1))
        $(call Image/Build/Profile/ESR-9753,$(1))
+       $(call Image/Build/Profile/F7C027,$(1))
        $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/FREESTATION5,$(1))
index 70d3fa94088f611bc1ae68c1cc3b6608646c15b0..47968ed4100557f2991a26979ae5705c9a2dd3ba 100644 (file)
@@ -17,4 +17,16 @@ define Profile/F5D8235V2/Description
        Package set for Belkin F5D8235 v2
 endef
 
+define Profile/F7C027
+       NAME:=Belkin F7C027
+        PACKAGES:=\
+                -kmod-usb-core -kmod-usb-rt305x-dwc_otg \
+                -kmod-ledtrig-usbdev
+endef
+
+define Profile/F7C027/Description
+       Package set for Belkin F7C027 - Plug with soc_ap and a relay
+endef
+
 $(eval $(call Profile,F5D8235V2))
+$(eval $(call Profile,F7C027))