add cdc-mbim module
authorJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:00:55 +0000 (10:00 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:00:55 +0000 (10:00 +0000)
http://patchwork.openwrt.org/patch/3370/

Signed-off-by: Rusink Rusinkoff <rzrusink@gmail.com>
SVN-Revision: 36184

package/kernel/modules/usb.mk

index 66e6e4aa7fb53ff602c2e6b08be0bfac77a65cd2..9548c02945f42c3498b157bcd75d4dd5cf411146 100644 (file)
@@ -842,6 +842,22 @@ endef
 
 $(eval $(call KernelPackage,usb-net-rndis))
 
+define KernelPackage/usb-net-cdc-mbim
+  SUBMENU:=$(USB_MENU)
+  TITLE:=Kernel module for MBIM Devices
+  KCONFIG:=CONFIG_USB_NET_CDC_MBIM
+  FILES:= \
+   $(LINUX_DIR)/drivers/$(USBNET_DIR)/cdc_mbim.ko
+  AUTOLOAD:=$(call AutoLoad,61,cdc_mbim)
+  $(call AddDepends/usb-net,+kmod-usb-wdm,+kmod-usb-net-cdc-ncm)
+endef
+
+define KernelPackage/usb-net-cdc-mbim/description
+ Kernel module for Option USB High Speed Mobile Devices
+endef
+
+$(eval $(call KernelPackage,usb-net-cdc-mbim))
+
 define KernelPackage/usb-net-cdc-ncm
   TITLE:=Support for CDC NCM connections
   KCONFIG:=CONFIG_USB_NET_CDC_NCM