iproute2: update to 5.0.0
authorDeng Qingfang <dengqf6@mail2.sysu.edu.cn>
Wed, 20 Mar 2019 08:05:14 +0000 (16:05 +0800)
committerHans Dedecker <dedeckeh@gmail.com>
Wed, 20 Mar 2019 20:48:04 +0000 (21:48 +0100)
Update iproute2 to 5.0.0
Remove upstream patch 001-tc-fix-undefined-XATTR_SIZE_MAX
Alter patch 170-ip_tiny as support for IPX and DECnet is dropped
Update patch 010-cake-fwmark to match upstream commit

Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/001-tc-fix-undefined-XATTR_SIZE_MAX.patch [deleted file]
package/network/utils/iproute2/patches/010-cake-fwmark.patch
package/network/utils/iproute2/patches/130-no_netem.patch
package/network/utils/iproute2/patches/135-sync-iptables-header.patch
package/network/utils/iproute2/patches/140-keep_libmnl_optional.patch
package/network/utils/iproute2/patches/170-ip_tiny.patch

index f284f8d060a6b09d3dbc84ecd00a5b014abcabc8..8617a8ef2f00ac5b7a60dbe032e92148514e3415 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=4.20.0
-PKG_RELEASE:=3
+PKG_VERSION:=5.0.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=c8adaa6a40f888476b23acb283cfa30c0dd55f07b5aa20663ed5ba2ef1f6fda8
+PKG_HASH:=df047302a39650ef832c07e8dab5df7a23218cd398bd310c8628e386161d20ba
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/001-tc-fix-undefined-XATTR_SIZE_MAX.patch b/package/network/utils/iproute2/patches/001-tc-fix-undefined-XATTR_SIZE_MAX.patch
deleted file mode 100644 (file)
index 6f28a28..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/tc/f_flower.c
-+++ b/tc/f_flower.c
-@@ -17,6 +17,7 @@
- #include <linux/if_arp.h>
- #include <linux/if_ether.h>
- #include <linux/ip.h>
-+#include <linux/limits.h>
- #include <linux/tc_act/tc_vlan.h>
- #include <linux/mpls.h>
index 43f776b4190085c19d6e977c110c914a1266270b..46981067bc3255afa647f75060854845a70126c8 100644 (file)
@@ -1,21 +1,18 @@
-From 9572f793e6945dd90a3cd4db34814b9b1616cfe9 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Toke=20H=C3=B8iland-J=C3=B8rgensen?= <toke@toke.dk>
-Date: Mon, 18 Mar 2019 01:30:19 +0100
-Subject: [PATCH] pkt_sched.h: Add support for CAKE FWMARK
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
+From a7cd7badedcb643dc1adb41edeb4cf8e4d9ec063 Mon Sep 17 00:00:00 2001
+From: Stephen Hemminger <stephen@networkplumber.org>
+Date: Tue, 19 Mar 2019 10:36:56 -0700
+Subject: uapi: add CAKE FWMARK
 
 
-Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
 ---
  include/uapi/linux/pkt_sched.h | 1 +
  1 file changed, 1 insertion(+)
 
 diff --git a/include/uapi/linux/pkt_sched.h b/include/uapi/linux/pkt_sched.h
 ---
  include/uapi/linux/pkt_sched.h | 1 +
  1 file changed, 1 insertion(+)
 
 diff --git a/include/uapi/linux/pkt_sched.h b/include/uapi/linux/pkt_sched.h
-index 01f96352..ef78de0c 100644
+index 1eb572e..7ee74c3 100644
 --- a/include/uapi/linux/pkt_sched.h
 +++ b/include/uapi/linux/pkt_sched.h
 --- a/include/uapi/linux/pkt_sched.h
 +++ b/include/uapi/linux/pkt_sched.h
-@@ -954,6 +954,7 @@ enum {
+@@ -1021,6 +1021,7 @@ enum {
        TCA_CAKE_INGRESS,
        TCA_CAKE_ACK_FILTER,
        TCA_CAKE_SPLIT_GSO,
        TCA_CAKE_INGRESS,
        TCA_CAKE_ACK_FILTER,
        TCA_CAKE_SPLIT_GSO,
index 58062655c9d59eebacc44c43ded41ea93d1de7f5..aa93366f29689bb75f0bd4bb4f149bcbbfa9661a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
 --- a/Makefile
 +++ b/Makefile
-@@ -61,7 +61,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
+@@ -55,7 +55,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
  CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
  YACCFLAGS = -d -t -v
  
  CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
  YACCFLAGS = -d -t -v
  
index a04d8ac742cdb34c1088afb82c8e3ee823d80d01..bba90e69abd7f95e2a1a381225f82444d12b440f 100644 (file)
@@ -7,7 +7,7 @@ Author: Cyril Brulebois <cyril@debamax.com>
 Last-Update: 2017-11-22
 --- a/include/xtables.h
 +++ b/include/xtables.h
 Last-Update: 2017-11-22
 --- a/include/xtables.h
 +++ b/include/xtables.h
-@@ -205,9 +205,24 @@ enum xtables_ext_flags {
+@@ -206,9 +206,24 @@ enum xtables_ext_flags {
        XTABLES_EXT_ALIAS = 1 << 0,
  };
  
        XTABLES_EXT_ALIAS = 1 << 0,
  };
  
@@ -34,7 +34,7 @@ Last-Update: 2017-11-22
        /*
         * ABI/API version this module requires. Must be first member,
         * as the rest of this struct may be subject to ABI changes.
        /*
         * ABI/API version this module requires. Must be first member,
         * as the rest of this struct may be subject to ABI changes.
-@@ -269,6 +284,10 @@ struct xtables_match
+@@ -270,6 +285,10 @@ struct xtables_match
        void (*x6_fcheck)(struct xt_fcheck_call *);
        const struct xt_option_entry *x6_options;
  
        void (*x6_fcheck)(struct xt_fcheck_call *);
        const struct xt_option_entry *x6_options;
  
@@ -45,7 +45,7 @@ Last-Update: 2017-11-22
        /* Size of per-extension instance extra "global" scratch space */
        size_t udata_size;
  
        /* Size of per-extension instance extra "global" scratch space */
        size_t udata_size;
  
-@@ -280,8 +299,7 @@ struct xtables_match
+@@ -281,8 +300,7 @@ struct xtables_match
        unsigned int loaded; /* simulate loading so options are merged properly */
  };
  
        unsigned int loaded; /* simulate loading so options are merged properly */
  };
  
@@ -55,7 +55,7 @@ Last-Update: 2017-11-22
        /*
         * ABI/API version this module requires. Must be first member,
         * as the rest of this struct may be subject to ABI changes.
        /*
         * ABI/API version this module requires. Must be first member,
         * as the rest of this struct may be subject to ABI changes.
-@@ -346,6 +364,10 @@ struct xtables_target
+@@ -347,6 +365,10 @@ struct xtables_target
        void (*x6_fcheck)(struct xt_fcheck_call *);
        const struct xt_option_entry *x6_options;
  
        void (*x6_fcheck)(struct xt_fcheck_call *);
        const struct xt_option_entry *x6_options;
  
@@ -66,7 +66,7 @@ Last-Update: 2017-11-22
        size_t udata_size;
  
        /* Ignore these men behind the curtain: */
        size_t udata_size;
  
        /* Ignore these men behind the curtain: */
-@@ -406,6 +428,17 @@ struct xtables_globals
+@@ -407,6 +429,17 @@ struct xtables_globals
  
  #define XT_GETOPT_TABLEEND {.name = NULL, .has_arg = false}
  
  
  #define XT_GETOPT_TABLEEND {.name = NULL, .has_arg = false}
  
@@ -84,7 +84,7 @@ Last-Update: 2017-11-22
  #ifdef __cplusplus
  extern "C" {
  #endif
  #ifdef __cplusplus
  extern "C" {
  #endif
-@@ -548,6 +581,14 @@ extern void xtables_lmap_free(struct xta
+@@ -549,6 +582,14 @@ extern void xtables_lmap_free(struct xta
  extern int xtables_lmap_name2id(const struct xtables_lmap *, const char *);
  extern const char *xtables_lmap_id2name(const struct xtables_lmap *, int);
  
  extern int xtables_lmap_name2id(const struct xtables_lmap *, const char *);
  extern const char *xtables_lmap_id2name(const struct xtables_lmap *, int);
  
index 505f0221e3ae11bc05cf081d9cc61623c8cf94ae..d255ae7b0e3b744e546e219187cc30b987faba32 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
 --- a/configure
 +++ b/configure
-@@ -254,7 +254,7 @@ check_selinux()
+@@ -255,7 +255,7 @@ check_selinux()
  
  check_mnl()
  {
  
  check_mnl()
  {
index 91240b6d2f4aa6c042f10775806157bde17bba94..fb5a6466e42634081d971f594c67a679f8eeb694 100644 (file)
@@ -41,7 +41,7 @@
 +#endif
  "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
  "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
 +#endif
  "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
  "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
- "                    -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n"
+ "                    -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
 @@ -72,32 +78,44 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
 @@ -72,32 +78,44 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "vrf",        do_ipvrf},
        { "sr",         do_seg6 },
        { "help",       do_help },
        { "vrf",        do_ipvrf},
        { "sr",         do_seg6 },
        { "help",       do_help },
---- a/lib/utils.c
-+++ b/lib/utils.c
-@@ -1000,6 +1000,7 @@ const char *rt_addr_n2a_r(int af, int le
-               return inet_ntop(af, addr, buf, buflen);
-       case AF_MPLS:
-               return mpls_ntop(af, addr, buf, buflen);
-+#ifndef IPROUTE2_TINY
-       case AF_IPX:
-               return ipx_ntop(af, addr, buf, buflen);
-       case AF_DECnet:
-@@ -1009,6 +1010,7 @@ const char *rt_addr_n2a_r(int af, int le
-               memcpy(dna.a_addr, addr, 2);
-               return dnet_ntop(af, &dna, buf, buflen);
-       }
-+#endif
-       case AF_PACKET:
-               return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
-       case AF_BRIDGE:
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -3,6 +3,10 @@ include ../config.mk
 --- a/lib/Makefile
 +++ b/lib/Makefile
 @@ -3,6 +3,10 @@ include ../config.mk