ath79: Add support for OpenMesh MR900 v2
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 19 Jan 2021 14:39:36 +0000 (15:39 +0100)
Device specifications:
======================

* Qualcomm/Atheros QCA9558 ver 1 rev 0
* 720/600/240 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 3T3R 2.4 GHz Wi-Fi
* 3T3R 5 GHz Wi-Fi
* 6x GPIO-LEDs (2x wifi, 2x status, 1x lan, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 1x ethernet
  - AR8035 ethernet PHY (RGMII)
  - 10/100/1000 Mbps Ethernet
  - 802.3af POE
  - used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[rebase, add LED migration]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 4847653f3f0714f9596c32f9020237ee48e157d5..fb025c95ea04a520e214b96e30048029435fb739 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=18
+PKG_RELEASE:=19
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 816d3b1a88f1297219c481b301f0de1ad94a7ed6..15994cec381d0658a33e340c5047e3ca465cebc4 100644 (file)
@@ -51,6 +51,7 @@ ocedo,raccoon|\
 openmesh,mr600-v1|\
 openmesh,mr600-v2|\
 openmesh,mr900-v1|\
+openmesh,mr900-v2|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts b/target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts
new file mode 100644 (file)
index 0000000..008caae
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_mr900.dtsi"
+
+/ {
+       compatible = "openmesh,mr900-v2", "qca,qca9558";
+       model = "OpenMesh MR900 v2";
+};
index 034c2d29336c00558e72fe1e83cd6dd43eff45cc..8fba9bc0e71b15a88cbc32e0bae2ad6fed887235 100755 (executable)
@@ -158,7 +158,8 @@ telco,t1)
 comfast,cf-wr752ac-v1|\
 engenius,eap300-v2|\
 enterasys,ws-ap3705i|\
-openmesh,mr900-v1)
+openmesh,mr900-v1|\
+openmesh,mr900-v2)
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
index 8a15d2ad55be0bf4cd5a00b96a22db6be04542be..76bbd92c210d5a89b5a894b6e4782121b2549849 100755 (executable)
@@ -49,6 +49,7 @@ ath79_setup_interfaces()
        openmesh,mr600-v1|\
        openmesh,mr600-v2|\
        openmesh,mr900-v1|\
+       openmesh,mr900-v2|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
index ad14eb2941d80126f2e7809101d9d70696763b58..453bf3b9112fb8a806addedcc83fa6e0d37d6c5b 100644 (file)
@@ -23,7 +23,8 @@ openmesh,mr600-v1)
 openmesh,mr600-v2)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
        ;;
-openmesh,mr900-v1)
+openmesh,mr900-v1|\
+openmesh,mr900-v2)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
        ;;
 pcs,cap324)
index 40197cfaa8e6469b54efdae82aa290998b40903e..76512758b6746230b8bf5a67bfaf1848a420fdb5 100644 (file)
@@ -53,6 +53,7 @@ platform_do_upgrade() {
        openmesh,mr600-v1|\
        openmesh,mr600-v2|\
        openmesh,mr900-v1|\
+       openmesh,mr900-v2|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
index 9d6fd398d95c11040b2ba1c4ce798ff4af641796..fec7f062153ca1be9ea5d0f5b7f92c8e46b0b34b 100644 (file)
@@ -1572,6 +1572,13 @@ define Device/openmesh_mr900-v1
 endef
 TARGET_DEVICES += openmesh_mr900-v1
 
+define Device/openmesh_mr900-v2
+  $(Device/openmesh_mr900-common)
+  DEVICE_VARIANT := v2
+  SUPPORTED_DEVICES += mr900v2
+endef
+TARGET_DEVICES += openmesh_mr900-v2
+
 define Device/openmesh_om2p-common
   DEVICE_VENDOR := OpenMesh
   DEVICE_PACKAGES := uboot-envtools