iptables: move IPTABLES_{CONNLABEL,NFTABLES} to libxtables
authorEtienne Champetier <champetier.etienne@gmail.com>
Mon, 21 Feb 2022 21:20:36 +0000 (16:20 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 28 Feb 2022 20:52:01 +0000 (21:52 +0100)
Those 2 configs are not specific to iptables(-legacy)

Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
package/network/utils/iptables/Makefile

index c5310838a3173a45a52a555d463d15374f08e79e..78d29089a3fd080122da9289649f5352d4da34af 100644 (file)
@@ -47,7 +47,6 @@ endef
 define Package/iptables
 $(call Package/iptables/Default)
   TITLE:=IP firewall administration tool
-  MENU:=1
   DEPENDS+= +kmod-ipt-core +libip4tc +IPV6:libip6tc +libxtables
   ALTERNATIVES:=\
     200:/usr/sbin/iptables:/usr/sbin/xtables-legacy-multi \
@@ -55,20 +54,6 @@ $(call Package/iptables/Default)
     200:/usr/sbin/iptables-save:/usr/sbin/xtables-legacy-multi
 endef
 
-define Package/iptables/config
-  config IPTABLES_CONNLABEL
-       bool "Enable Connlabel support"
-       default n
-       help
-               This enable connlabel support in iptables.
-
-  config IPTABLES_NFTABLES
-       bool "Enable Nftables support"
-       default y
-       help
-               This enable nftables support in iptables.
-endef
-
 define Package/iptables/description
 IP firewall administration tool.
 
@@ -525,10 +510,25 @@ define Package/libxtables
  SECTION:=libs
  CATEGORY:=Libraries
  TITLE:=IPv4/IPv6 firewall - shared xtables library
+ MENU:=1
  ABI_VERSION:=12
  DEPENDS:=+IPTABLES_CONNLABEL:libnetfilter-conntrack
 endef
 
+define Package/libxtables/config
+  config IPTABLES_CONNLABEL
+       bool "Enable Connlabel support"
+       default n
+       help
+               This enable connlabel support in iptables.
+
+  config IPTABLES_NFTABLES
+       bool "Enable Nftables support"
+       default y
+       help
+               This enable nftables support in iptables.
+endef
+
 define Package/libxtables-nft
  $(call Package/iptables/Default)
  SECTION:=libs