samba36: fix build (issue #5574)
authorJakub Tymejczyk <jakub@tymejczyk.pl>
Wed, 21 Feb 2018 11:55:31 +0000 (12:55 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 24 Feb 2018 10:23:46 +0000 (11:23 +0100)
As indicated in #5574 samba fails to build with linker error due to lack
of talloc_* functions when the packet libtalloc also gets build.

According to Makefile it is compiled with "--without-libtalloc" option.
Running ./configure --help shows that there is another option connected
to libtalloc: --enable/disable-external-libtalloc.
Adding this option fixes build.

Signed-off-by: Jakub Tymejczyk <jakub@tymejczyk.pl>
package/network/services/samba36/Makefile

index 42c23b4e8ee591a49d862b1f881c42dbad74ea25..55e1428d49e1efa305a7085e86cc9ee89300603b 100644 (file)
@@ -101,6 +101,7 @@ CONFIGURE_ARGS += \
        --prefix=/ \
        --disable-avahi \
        --disable-cups \
        --prefix=/ \
        --disable-avahi \
        --disable-cups \
+       --disable-external-libtalloc \
        --disable-pie \
        --disable-relro \
        --disable-static \
        --disable-pie \
        --disable-relro \
        --disable-static \