uboot-envtools: add configuration for UniElec U7623 board
authorDaniel Golle <daniel@makrotopia.org>
Mon, 10 Jan 2022 17:09:27 +0000 (17:09 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 23 Jan 2022 20:20:42 +0000 (20:20 +0000)
Add U-Boot env settings to allow accessing the environment using
fw_printenv and fw_setenv tools on the UniElec U7623 board.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/uboot-envtools/files/mediatek_mt7623
target/linux/mediatek/image/mt7623.mk

index 863c8bc2110ae8284e28e98dca6b24d7b67816bf..fd2a01006a8e08436106788b022a90f136ba3ea5 100644 (file)
@@ -17,6 +17,10 @@ bananapi,bpi-r2)
        export_bootdevice
        export_partdevice ubootpart 1
        ubootenv_add_uci_config "/dev/$ubootpart" "0xb0000" "0x10000" "0x10000" "1"
+       ;;
+unielec,u7623-02)
+       ubootenv_add_uci_config "/dev/mmcblk0p1" "0xc0000" "0x10000" "0x10000" "1"
+       ;;
 esac
 
 config_load ubootenv
index cad3dd2b93803b75c1e3d1737fed3974f2d6b326..89c771e5a06c75fa96d1e7ee32b1b308e4998422 100644 (file)
@@ -172,11 +172,11 @@ define Device/unielec_u7623-02-emmc-512m-legacy
   DEVICE_PACKAGES := kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 kmod-mmc \
        mkf2fs e2fsprogs kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk \
        partx-utils
-  IMAGES := sysupgrade-emmc.bin.gz
-  IMAGE/sysupgrade-emmc.bin.gz := append-kernel |\
-                                   pad-to 4864k | fat-recovery-fs |\
-                                   pad-to 7936k | append-rootfs |\
-                                   gzip | append-metadata
+  IMAGES := sysupgrade.bin.gz
+  IMAGE/sysupgrade.bin.gz := append-kernel |\
+                               pad-to 4864k | fat-recovery-fs |\
+                               pad-to 7936k | append-rootfs |\
+                               gzip | append-metadata
   SUPPORTED_DEVICES := unielec,u7623-02-emmc-512m
 endef
 TARGET_DEVICES += unielec_u7623-02-emmc-512m-legacy