Also package exportfs for nfsd to work properly on 2.6 kernels (#1899)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 14 Jun 2007 07:45:33 +0000 (07:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 14 Jun 2007 07:45:33 +0000 (07:45 +0000)
SVN-Revision: 7627

package/kernel/modules/fs.mk

index f28c9ad68bc8e06794664cbbb1c7288185ac2590..3e8cd7c28689169403faa7d582d2494e8a31159a 100644 (file)
@@ -106,10 +106,19 @@ define KernelPackage/fs-nfsd
   DESCRIPTION:=Kernel module for NFS kernel server support
   KCONFIG:=$(CONFIG_NFSD)
   SUBMENU:=$(FSMENU)
   DESCRIPTION:=Kernel module for NFS kernel server support
   KCONFIG:=$(CONFIG_NFSD)
   SUBMENU:=$(FSMENU)
-  AUTOLOAD:=$(call AutoLoad,30,nfsd)
   FILES:= \
        $(LINUX_DIR)/fs/nfsd/nfsd.$(LINUX_KMOD_SUFFIX)
 endef
   FILES:= \
        $(LINUX_DIR)/fs/nfsd/nfsd.$(LINUX_KMOD_SUFFIX)
 endef
+
+define KernelPackage/fs-nfsd/2.4
+  AUTOLOAD:=$(call AutoLoad,30,nfsd)
+endef
+
+define KernelPackage/fs-nfsd/2.6
+  FILES+=$(LINUX_DIR)/fs/exportfs/exportfs.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,exportfs nfsd)
+endef
+
 $(eval $(call KernelPackage,fs-nfsd))
 
 define KernelPackage/fs-msdos
 $(eval $(call KernelPackage,fs-nfsd))
 
 define KernelPackage/fs-msdos