ipq40xx: convert to DSA and enable Sony NCP-HG100/Cellular
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Wed, 5 Oct 2022 14:35:21 +0000 (23:35 +0900)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 9 Oct 2022 20:45:06 +0000 (22:45 +0200)
This patch converts networking on Sony NCP-HG100/Cellular to DSA and
re-enables support for the device.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
target/linux/ipq40xx/base-files/etc/board.d/01_leds
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-ncp-hg100-cellular.dts
target/linux/ipq40xx/image/generic.mk

index 74f31e778f291504adcf231ee065267bad87a0e9..cd68ed32c01e4a778d9954e871a4d7dbbd43d45c 100644 (file)
@@ -95,8 +95,8 @@ qxwlan,e2600ac-c2)
        ucidef_set_led_wlan "wlan5g" "WLAN1" "green:wlan1" "phy1tpt"
        ;;
 sony,ncp-hg100-cellular)
-       ucidef_set_led_netdev "lan" "LAN" "green:lan" "eth0"
-       ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth1"
+       ucidef_set_led_netdev "lan" "LAN" "green:lan" "lan"
+       ucidef_set_led_netdev "wan" "WAN" "green:wan" "wan"
        ucidef_set_led_netdev "wwan" "WWAN" "green:wan-4" "wwan0"
        ;;
 zyxel,nbg6617 |\
index 583b5c8fbd22603946fcfd3bde230aaede88088f..1089a7f3f81d61d5a8203ac0ecf4f65201050d7a 100644 (file)
@@ -34,6 +34,7 @@ ipq40xx_setup_interfaces()
        luma,wrtq-329acn|\
        mikrotik,cap-ac|\
        netgear,wac510|\
+       sony,ncp-hg100-cellular|\
        zte,mf289f)
                ucidef_set_interfaces_lan_wan "lan" "wan"
                ;;
index f1ac5fd52f5b67831a133b6c22118fc72379d1a7..ea27defea3de85b6da8e605b96b6ddba63e22498 100644 (file)
@@ -16,7 +16,7 @@
                led-failsafe = &led_cloud_red;
                led-running = &led_cloud_green;
                led-upgrade = &led_cloud_green;
-               label-mac-device = &gmac0;
+               label-mac-device = &gmac;
        };
 
        chosen {
                        qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
                };
 
-               ess-psgmii@98000 {
-                       status = "okay";
-               };
-
                dma@7984000 {
                        status = "okay";
                };
-
-               ess-switch@c000000 {
-                       status = "okay";
-                       switch_mac_mode = <0x0>; /* mac mode for RGMII RMII */
-                       switch_initvlas = <0x0007c 0x54>; /* PORT0_STATUS */
-               };
-
-               edma@c080000 {
-                       status = "okay";
-               };
        };
 
        keys-repeat {
        status = "okay";
 };
 
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport4 {
+       status = "okay";
+       label = "lan";
+};
+
+&swport5 {
+       status = "okay";
+       label = "wan";
+};
+
 &wifi0 {
        status = "okay";
        qcom,ath10k-calibration-variant = "Sony-NCP-HG100-Cellular";
index 82c7464b871c7787b0f03341f3dd30c67fda4cc2..68ce31c20582274154d3b4756809b9bc77370ba5 100644 (file)
@@ -1048,8 +1048,7 @@ define Device/sony_ncp-hg100-cellular
        DEVICE_PACKAGES := e2fsprogs ipq-wifi-sony_ncp-hg100-cellular \
                kmod-fs-ext4 uqmi
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += sony_ncp-hg100-cellular
+TARGET_DEVICES += sony_ncp-hg100-cellular
 
 define Device/teltonika_rutx10
        $(call Device/FitImage)