ipq40xx: fix 4.14 ImageBuilder build woes
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 3 Jan 2019 22:24:16 +0000 (23:24 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 5 Jan 2019 21:23:10 +0000 (22:23 +0100)
Robert Marko reported an issue with the current imagebuilder images:
"Imagebuilder includes the new kmod-usb-dwc3-qcom USB driver
package by default even on 4.14. [...] the current state imagebuilder
can't build images under 4.14 at all as the kmod-usb-dwc3-qcom does
not exist in it so it throws and error and exits."

This patch reverts the Makefile to just kmod-usb-dwc3-of-simple and
once the switch to 4.19 is done. It also removes the
kmod-usb-phy-qcom-dwc3 as they only contain the usb-phy drivers for
the ipq806x generation.

Dynamic switching based on the KERNEL_PATCHVER is possible by using:
   $(if $(filter 4.14,$(KERNEL_PATCHVER)),kmod-usb-dwc3-of-simple,kmod-usb-dwc3-qcom)
though it

Fixes: 13321fa1429 ("ipq40xx: Use kmod-usb-dwc3-qcom by default")
Fixes: 6e58fb2c33e ("ipq40xx: kmod-usb-dwc3-of-simple vs kmod-usb-dwc3-qcom")
Reported-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ipq40xx/Makefile

index 4813ad24254cfd23faff6cd00773bcd666e4e2e1..ab7b174e4000063e585d53368d48174663b52014 100644 (file)
@@ -15,9 +15,9 @@ KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
+       kmod-usb-dwc3-of-simple \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ath10k-ct wpad-basic \
-       kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
-       kmod-usb-dwc3-qcom ath10k-firmware-qca4019-ct
+       kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
 
 $(eval $(call BuildTarget))