add elinks, mutt, fetchmail and procmail, thx Michael Cohen, procmail disabled, compi...
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 15 Mar 2006 16:52:29 +0000 (16:52 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 15 Mar 2006 16:52:29 +0000 (16:52 +0000)
SVN-Revision: 3379

15 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/elinks/Config.in [new file with mode: 0644]
openwrt/package/elinks/Makefile [new file with mode: 0644]
openwrt/package/elinks/ipkg/elinks.control [new file with mode: 0644]
openwrt/package/fetchmail/Config.in [new file with mode: 0644]
openwrt/package/fetchmail/Makefile [new file with mode: 0644]
openwrt/package/fetchmail/ipkg/fetchmail.control [new file with mode: 0644]
openwrt/package/jamvm/Config.in
openwrt/package/mutt/Config.in [new file with mode: 0644]
openwrt/package/mutt/Makefile [new file with mode: 0644]
openwrt/package/mutt/ipkg/mutt.control [new file with mode: 0644]
openwrt/package/procmail/Config.in [new file with mode: 0644]
openwrt/package/procmail/Makefile [new file with mode: 0644]
openwrt/package/procmail/ipkg/procmail.control [new file with mode: 0644]

index 05b736f8108bc69259b3d1e5ba7fd29e15b74610..9c63091e70e8783ef594438b703693411dd9b56d 100644 (file)
@@ -20,6 +20,8 @@ source "package/collectd/Config.in"
 source "package/cbtt/Config.in"
 source "package/ctorrent/Config.in"
 source "package/deco/Config.in"
+source "package/elinks/Config.in"
+source "package/fetchmail/Config.in"
 source "package/gpsd/Config.in"
 source "package/haserl/Config.in"
 source "package/irssi/Config.in"
@@ -29,6 +31,9 @@ source "package/less/Config.in"
 source "package/lua/Config.in"
 source "package/microperl/Config.in"
 source "package/monit/Config.in"
+source "package/mutt/Config.in"
+source "package/procmail/Config.in"
+
 source "package/nano/Config.in"
 source "package/osiris/Config.in"
 source "package/php4/Config.in"
index 856b7eb90024c7256ae36f50faf2fa2647e5faa9..94c0ebfa7ef67e1102dc84b09568b818e3e2dace 100644 (file)
@@ -43,9 +43,11 @@ package-$(BR2_PACKAGE_DROPBEAR) += dropbear
 package-$(BR2_PACKAGE_DSNIFF) += dsniff
 package-$(BR2_PACKAGE_E2FSPROGS) += e2fsprogs
 package-$(BR2_PACKAGE_EBTABLES) += ebtables
+package-$(BR2_PACKAGE_ELINKS) += elinks
 package-$(BR2_PACKAGE_ETHER_WAKE) += ether-wake
 package-$(BR2_COMPILE_EXPAT) += expat
 package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
+package-$(BR2_PACKAGE_FETCHMAIL) += fetchmail
 package-$(BR2_COMPILE_FLAC) += flac
 package-$(BR2_PACKAGE_FPING) += fping
 package-$(BR2_PACKAGE_FPROBE) += fprobe
@@ -145,6 +147,7 @@ package-$(BR2_PACKAGE_MRD6) += mrd6
 package-$(BR2_PACKAGE_MT_DAAPD) += mt-daapd
 package-$(BR2_PACKAGE_MTD) += mtd
 package-$(BR2_PACKAGE_MTR) += mtr
+package-$(BR2_PACKAGE_MUTT) += mutt
 package-$(BR2_COMPILE_MYSQL) += mysql
 package-$(BR2_PACKAGE_NANO) += nano
 package-$(BR2_COMPILE_NCURSES) += ncurses
@@ -188,6 +191,7 @@ package-$(BR2_PACKAGE_PPP) += ppp
 package-$(BR2_PACKAGE_PPTP) += pptp
 package-$(BR2_PACKAGE_PPTPD) += pptpd
 package-$(BR2_PACKAGE_PRIVOXY) += privoxy
+package-$(BR2_PACKAGE_PROCMAIL) += procmail
 package-$(BR2_PACKAGE_PSYBNC) += psybnc
 package-$(BR2_PACKAGE_PTUNNEL) += ptunnel
 package-$(BR2_PACKAGE_QUAGGA) += quagga
@@ -337,6 +341,7 @@ miredo-compile: uclibc++-compile
 monit-compile: openssl-compile
 mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
 mtr-compile: ncurses-compile
+mutt-compile: ncurses-compile openssl-compile
 mysql-compile: ncurses-compile zlib-compile readline-compile
 nano-compile: ncurses-compile
 net-snmp-compile: libelf-compile
diff --git a/openwrt/package/elinks/Config.in b/openwrt/package/elinks/Config.in
new file mode 100644 (file)
index 0000000..3e0b28c
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_ELINKS
+       prompt "elinks............................ A text based web browser"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         An advanced text based web browser
+
+         http://elinks.or.cz/
+
diff --git a/openwrt/package/elinks/Makefile b/openwrt/package/elinks/Makefile
new file mode 100644 (file)
index 0000000..07fc516
--- /dev/null
@@ -0,0 +1,56 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elinks
+PKG_VERSION:=0.11.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://elinks.or.cz/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=c09d726075e4b5810fa07f8654088755
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,ELINKS,elinks,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $${x}=yes && \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+               ac_cv_c_bigendian=no \
+               ac_cv_sizeof_off_t=8 \
+               ac_cv_file___features_conf=yes \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --disable-largefile\
+               --disable-formhist\
+               --disable-mailcap\
+               --disable-data\
+               --disable-uri-rewrite\
+               --enable-256-colors\
+               --disable-backtrace\
+               --enable-small\
+               --without-spidermonkey\
+               --without-x\
+               --disable-ipv6 \
+               $(DISABLE_NLS) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR)\
+               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld
+       touch $@
+
+$(IPKG_ELINKS): 
+       mkdir -p $(IDIR_ELINKS)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/elinks $(IDIR_ELINKS)/usr/bin/
+       $(RSTRIP) $(IDIR_ELINKS)
+       $(IPKG_BUILD) $(IDIR_ELINKS) $(PACKAGE_DIR)
diff --git a/openwrt/package/elinks/ipkg/elinks.control b/openwrt/package/elinks/ipkg/elinks.control
new file mode 100644 (file)
index 0000000..f3de4e5
--- /dev/null
@@ -0,0 +1,4 @@
+Package: elinks
+Priority: optional
+Section: text
+Description: An advanced text web browser
diff --git a/openwrt/package/fetchmail/Config.in b/openwrt/package/fetchmail/Config.in
new file mode 100644 (file)
index 0000000..bc6cdfe
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FETCHMAIL
+       prompt "fetchmail......................... Remote mail retriever"
+       tristate
+       default m if CONFIG_DEVEL
+       help
+               Retrieves remote mail via POP/IMAP
+
+               Very useful in conjunction with mutt.
diff --git a/openwrt/package/fetchmail/Makefile b/openwrt/package/fetchmail/Makefile
new file mode 100644 (file)
index 0000000..1ca6cd7
--- /dev/null
@@ -0,0 +1,59 @@
+# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fetchmail
+PKG_VERSION:=6.2.5
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FETCHMAIL,fetchmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ac_cv_c_bigendian=no \
+               ac_cv_sizeof_off_t=8 \
+               ac_cv_sizeof_int=4 \
+               ac_cv_sizeof_long=4 \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               --program-prefix="" \
+               --enable-fallback=procmail \
+               $(DISABLE_NLS) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC)
+       touch $@
+
+$(IPKG_FETCHMAIL): 
+       mkdir -p $(IDIR_FETCHMAIL)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_FETCHMAIL)/usr/bin/
+       $(RSTRIP) $(IDIR_FETCHMAIL)
+       $(IPKG_BUILD) $(IDIR_FETCHMAIL) $(PACKAGE_DIR)
diff --git a/openwrt/package/fetchmail/ipkg/fetchmail.control b/openwrt/package/fetchmail/ipkg/fetchmail.control
new file mode 100644 (file)
index 0000000..ea664fa
--- /dev/null
@@ -0,0 +1,5 @@
+Package: fetchmail
+Priority: optional
+Section: text
+Depends: 
+Description: Mail text client
index befdfa9e6f29b110a4748436922645dd80dc4df7..15af752312bb1a54b7ffba55b26d233eaeafacd5 100644 (file)
@@ -1,15 +1,17 @@
 config BR2_PACKAGE_JAMVM
-        prompt "jamvm .............................A compact Java Virtual Machine"
+        prompt "jamvm ............................A compact Java Virtual Machine"
        tristate
         default m if CONFIG_DEVEL
        select BR2_PACKAGE_ZLIB
        select BR2_PACKAGE_LIBFFI_SABLE
        select BR2_PACKAGE_LIBSABLEVM_CLASSPATH
         help
-          JamVM is a new Java Virtual Machine which conforms to the JVM specification version
-          (blue book). In comparison to most other VM's (free and commercial) it is extremely
-          small.However, unlike other small VMs (e.g. KVM) it is designed to support the full
-          specification, and includes support for object finalisation, Soft/Weak/Phantom 
-         References, the Java Native Interface (JNI) and the Reflection API.
+         JamVM is a new Java Virtual Machine which conforms to the JVM
+         specification version (blue book). In comparison to most other VM's
+         (free and commercial) it is extremely small.However, unlike other
+         small VMs (e.g. KVM) it is designed to support the full
+         specification, and includes support for object finalisation,
+         Soft/Weak/Phantom References, the Java Native Interface (JNI) and the
+         Reflection API.
 
          http://sourceforge.net/projects/jamvm
diff --git a/openwrt/package/mutt/Config.in b/openwrt/package/mutt/Config.in
new file mode 100644 (file)
index 0000000..211d58c
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_MUTT
+       prompt "mutt.............................. console mail client"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBNCURSES
+       select BR2_PACKAGE_LIBOPENSSL
+       help
+         Mail client for the text console
+         
+         http://www.mutt.org
+
diff --git a/openwrt/package/mutt/Makefile b/openwrt/package/mutt/Makefile
new file mode 100644 (file)
index 0000000..b338963
--- /dev/null
@@ -0,0 +1,63 @@
+# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mutt
+PKG_VERSION:=1.4.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=ftp://ftp.mutt.org/mutt/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)i.tar.gz
+PKG_MD5SUM:=710bd56d3c4c4bcd1403bc4e053f7476
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MUTT,mutt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ac_cv_c_bigendian=no \
+               ac_cv_sizeof_off_t=8 \
+               ac_cv_sizeof_int=4 \
+               ac_cv_sizeof_long=4 \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               --program-prefix="" \
+               --includedir=. \
+               --oldincludedir=. \
+               --enable-pop \
+               --enable-imap \
+               --with-ssl \
+               $(DISABLE_NLS) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC)
+       touch $@
+
+$(IPKG_MUTT): 
+       mkdir -p $(IDIR_MUTT)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_MUTT)/usr/bin/
+       $(RSTRIP) $(IDIR_MUTT)
+       $(IPKG_BUILD) $(IDIR_MUTT) $(PACKAGE_DIR)
diff --git a/openwrt/package/mutt/ipkg/mutt.control b/openwrt/package/mutt/ipkg/mutt.control
new file mode 100644 (file)
index 0000000..4930748
--- /dev/null
@@ -0,0 +1,5 @@
+Package: mutt
+Priority: optional
+Section: text
+Depends: libncurses, libopenssl
+Description: Mail text client
diff --git a/openwrt/package/procmail/Config.in b/openwrt/package/procmail/Config.in
new file mode 100644 (file)
index 0000000..548b8e6
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PROCMAIL
+       prompt "procmail.......................... mail processing tool"
+       tristate
+       default n
+       help
+         Procmail is able to process and classify incoming mail into
+         different mail boxes.
+
+         Very useful in conjunction with mutt.
+       
+         http://www.procmail.org
diff --git a/openwrt/package/procmail/Makefile b/openwrt/package/procmail/Makefile
new file mode 100644 (file)
index 0000000..ce7909c
--- /dev/null
@@ -0,0 +1,33 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=procmail
+PKG_VERSION:=3.22
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.procmail.org/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=1678ea99b973eb77eda4ecf6acae53f1
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PROCMAIL,procmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)/ init \
+               CC=$(TARGET_CC)
+
+       echo yes | $(MAKE) -C $(PKG_BUILD_DIR)/src/ procmail formail \
+               CC=$(TARGET_CC)
+       touch $@
+
+$(IPKG_PROCMAIL): 
+       mkdir -p $(IDIR_PROCMAIL)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/procmail $(IDIR_PROCMAIL)/usr/bin/ 
+       $(CP) $(PKG_BUILD_DIR)/src/formail $(IDIR_PROCMAIL)/usr/bin/
+       $(RSTRIP) $(IDIR_PROCMAIL)
+       $(IPKG_BUILD) $(IDIR_PROCMAIL) $(PACKAGE_DIR)
diff --git a/openwrt/package/procmail/ipkg/procmail.control b/openwrt/package/procmail/ipkg/procmail.control
new file mode 100644 (file)
index 0000000..6a87f9f
--- /dev/null
@@ -0,0 +1,4 @@
+Package: procmail
+Priority: optional
+Section: text
+Description: Mail processing tool