util-linux: Subpackage for blkdiscard
authorJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:30:56 +0000 (08:30 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 12 Feb 2016 08:30:56 +0000 (08:30 +0000)
Adding subpackage to make it possible to enable blkdiscard utility.

Signed-off-by: Michal Hrusecky <Michal.Hrusecky@nic.cz>
SVN-Revision: 48707

package/utils/util-linux/Makefile

index eddbc2b77a4be6736e1cdac4f908472a20022630..73903cd92d0cf6fdd0c3851c44613914e4a73806 100644 (file)
@@ -137,6 +137,18 @@ define Package/agetty/description
  /bin/login command
 endef
 
+define Package/blkdiscard
+$(call Package/util-linux/Default)
+  TITLE:=discard sectors on a device
+  SUBMENU=disc
+endef
+
+define Package/blkdiscard/description
+ The blkdiscard is used to discard device sectors. This is useful for
+ solid-state drivers (SSDs) and thinly-provisioned storage. Unlike fstrim,
+ this command is used directly on the block device.
+endef
+
 define Package/blkid
 $(call Package/util-linux/Default)
   TITLE:=locate/print block device attributes
@@ -462,6 +474,11 @@ define Package/agetty/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/agetty $(1)/usr/sbin/
 endef
 
+define Package/blkdiscard/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/blkdiscard $(1)/usr/sbin/
+endef
+
 define Package/blkid/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/blkid $(1)/usr/sbin/
@@ -613,6 +630,7 @@ $(eval $(call BuildPackage,libmount))
 $(eval $(call BuildPackage,libsmartcols))
 $(eval $(call BuildPackage,libuuid))
 $(eval $(call BuildPackage,agetty))
+$(eval $(call BuildPackage,blkdiscard))
 $(eval $(call BuildPackage,blkid))
 $(eval $(call BuildPackage,cal))
 $(eval $(call BuildPackage,cfdisk))