procd: update to latest git HEAD
authorJohn Crispin <john@phrozen.org>
Thu, 28 Sep 2017 06:30:04 +0000 (08:30 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 28 Sep 2017 07:22:02 +0000 (09:22 +0200)
ee582d1 instance: properly compare and reload respawn config
260a4cd utrace: Start the tracee only after uloop initialization
520ad3c utrace: Switch all logging to ulog
1c48104 utrace: Support non-contiguous syscall numbers
582cf97 utrace: Forward SIGTERM to the traced process
32534f7 utrace: Report ptrace errors
ccde3fb seccomp: Improve error message
7f9b174 preload-seccomp: Use proper log level for error messages
e3c4302 Start seccomp-enabled services via seccomp-trace
5e4ad02 seccomp: Log seccomp violations with utrace
2661b2f utrace: Use PTHREAD_SEIZE instead of PTHREAD_TRACEME
b5d53c6 utrace: Deliver signals to traced processes
b416ed9 utrace: Support tracing multi-threaded processes and vfork
8b7d47a utrace: Trace processes across forks
c6b6ec6 utrace: Sort syscalls by number of invocations
592c532 Update trace attribute
c8faedc Do not disable seccomp when configuration is not found
017f3a1 utrace: Fix off-by-one errors
5acaf15 utrace: Fix environment initialization

Signed-off-by: John Crispin <john@phrozen.org>
package/system/procd/Makefile

index 5f2d21c102c7781ce047b166d61354f0f7430eb7..6ab4f4870f271b1b294176e14076b4db4ec83aa4 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(LEDE_GIT)/project/procd.git
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(LEDE_GIT)/project/procd.git
-PKG_SOURCE_DATE:=2017-08-22
-PKG_SOURCE_VERSION:=54b46a351fab736a92221a6f9c750b5f9da499a1
-PKG_MIRROR_HASH:=dcbeea89910bbdf7d6cf20c38892d6c51de375c8b35c372a7106ae17090694f3
+PKG_SOURCE_DATE:=2017-09-28
+PKG_SOURCE_VERSION:=ee582d16c7ebbfbcc5e3c4f8970f5e376c406f5f
+PKG_MIRROR_HASH:=c47459524647763150bb75cf030dca25786c27f3fd16fd88627f2a998ffa615e
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0